Trunk shows up as offline but still works

freepbx
configuration
Tags: #<Tag:0x00007f7028ec1f90> #<Tag:0x00007f7028ec1db0>

#1

I registered 2 trunks, but the second one shows up as “OFFLINE”
But when I call the number, I still receive the call just fine. It works as expected.

What could I be doing wrong here?


4


#2

Was this question moved to “Providers” because its considered a provider issue?


(Joshua C. Colp) #3

Not explicitly. Categories are general grouped things. In this case since it involves a trunk which is usually to a provider, I moved it there.


(Dave Burgess) #4

IIRC, Asterisk doesn’t normally differentiate between multiple trunks to the same provider IP, which this appears to be. Most providers lump all numbers for a specific endpoint into the first trunk that appears, so the second trunk would be ignored. This would make sense, since all Inbound Routes are interrogated whenever a new call comes in regardless of the source trunk.

Not sure that’s what’s happening here, but it might be worth checking with the provider to see if they are expecting to send all of your calls down the same trunk. If they are only expecting one trunk (with multiple DIDs) then you may need to adjust your trunk config to match their expectation.


#5

Their trunks have always been separate, I’ve been using them with other freepbx installations and this is the first time I see this behaviour.

This was their reply.
We see no reason for such a status. On the server side, registration is successful.
Please check the settings according to the instructions:
https://zadarma.com/en/support/instructions/freepbx/freepbx14/

And it makes sense, freepbx also states that the trunk is registered successfully.

I need to find out what the OFFLINE status means.