Trunk Registration Timed Out on all trunks

Hi, can anyone help with a problem that I’m having with FreePBX I have 6 trunks which have been working fine (5 from 1 provider and 1 from another provider).

Now I’m getting registration errors on all 6 trunks. I’ve been trying to research online but no luck so far. Here is an example of the message “[2018-05-16 16:05:06] NOTICE[2348]: chan_sip.c:15890 sip_reg_timeout: – Registration for ‘[email protected]’ timed out, trying again (Attempt #538)”.

Not sure what is happening. I have only done module updates and system updates. I’ve rebooted also. Any help or suggestions would be greatly appreciated.

Just a random suggestion.
Have you tried using chan_pjsip instead of chan_sip ?
Do you experience same problem ?

So I tried setting up a trunk as pjsip and it did connect even though the carrier doesn’t really support it. I’m still confused why all my SIP trunks that were working with no problem before are not working at all now. Not sure if it’s a asterisk/freepbx problem or router issue.

I disabled my firewall in FreePbx to see if that would make a difference but it didn’t.

I turned on debug and here are the results from one of the trunks. I removed acct names and ip addresses.

Retransmitting #3 (NAT) to sip_provider_ip:5060:
Via: SIP/2.0/UDP mypublicip:5160;branch=z9hG4bK031c8385;rport
Max-Forwards: 70
From: sip:[email protected];tag=as4fa92251
To: sip:[email protected]
Call-ID: [email protected]
Supported: replaces, timer
User-Agent: FPBX-
Expires: 120
Contact: sip:[email protected]:5160
Content-Length: 0

is your pbx behind a router?

It connects through a Unifi Security Gateway (USG) that connects to the DMZ of AT&T modem.

not sure why you don’t just put the att modem in pass through mode, then you can control everything with you USG.

I usually put modems like that in bridge mode but this model does not have that. At least not that I could find. It’s a PACE Model 5268AC FXN. Everything has been working great and I haven’t changed anything on the modem or gateway and do regular updated to the modules and system through Freepbx GUI. Apparently something has changed somewhere but I have no clue what is causing the issue.

maybe att made an update to their modem. I have not looked at the PACE modems in a long time, but there should be a way to turn off the firewall and if you have a dynamic ip, to get the modem to pass that ip through to your router. everything you are describing points to a firewall issue.

I checked my AT&T Modem. My router is showing in the DMZPlus receiving the external ip address and the Firewall is set to Allow all applications, All Protocols, All Port numbers for the public ip. My WAN on the gateway is showing the same external ip address that the AT&T modem is showing.

i guess the next step is wireshark

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.