Trunk REGISTRATION after Restart-- FreePBX

Hosted system: Host company restarted equipment and Freepbx came back up but problem with trunks working.
The system showed trunks registered but the trunking company would not register. After working with tech support, found after rebooting the hardware and the pbx is up and running, had to issue a “fwconsole reload” command in order to register trunks with trunking company.
Is there a fix for this?
Not until this command was issued would the trunks connect though pbx showed registered the whole time.

Was it restarted safely?

What I have learned is it seems to be a firewall issue. Upon booting up, the system is in a safe mode for 5-minutes and trunk registers until the time limit. Trying disable firewall after the fact, the same one that is part of the safe mode, does not change anything, still cannot register until I run
“fwconsole reload”.
also added sip trunks as trusted.

probably not

Then that’s probably why.

Try rebooting your PBX through the GUI and see if it happens again…

The first assumption was that the hosting company, who had to restart their node, did it unsafely? That they would just risk possible destruction/corruption of all the hosts on the node for their customers?

A “Reload” is not a “Restart”. A “Reload” takes the config files and reads them into Memory to pick up the changes that have been made. In the case of SIP peers with outbound registrations (ie your SIP Trunks) it causes a new REGISTER to be sent.

A “Restart” is going to shut every service down, in order, and then start them again in the proper order. If this was really an issue with a bad reboot and services not starting up properly or in the correct order when the server came back up then a “Reload” wouldn’t have fixed the issue.

I’m going to guess, based on experience, that the server restarted the services came up and the PBX sent a REGISTER, the other side got it but might have screwed up the Location storage because it either conflicted in some other way or the Expire attribute wasn’t accepted properly. So the PBX got a 200 OK for its REGISTER that’s why it thinks it is registered but the provider had expired the location.

Basically a the “fwconsole reload” make the SIP trunk issue a new REGISTER and it fixed the issue. It could have just been a simple asterisk -rx “sip reload” , etc to make it happen as well.

Asterisk Version: 13.19.1

UPDATE> Disabling firewall and reboot, had the same results, no registration after about 5-minutes. Issue the fwconsole command and it came back and then enable firewall.

The strange thing is it only effects sip registration on the provider side (the provider dashboard showing unregistered), the system thinks it is registered always showing registered.
Also tried a different sip provider having the same results, fwconsole reload fixes the problem after the reboot.
That was a good test but had the same results, no registration after about 5-minutes.

I appreciate and welcome any ideas or solutions.

PS> Getting whole lot of these kind of errors whether this is assoicated or not WARNING[1903]: res_pjsip_registrar.c:963 registrar_on_rx_request: Endpoint ‘anonymous’ has no configured AORs

If multiple providers are dropping your Location after you make a successful REGISTER then it most likely means they are not getting any response from your side when they are pinging/keep-alive’ing your endpoint.

Is the PBX directly on the Internet or is it behind a firewall/router?

This is a hosted pbx with a public IP, using Freepbx responsive firewall.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.