Trunk Register String fail


My Name is Raj and I am working a for a school as sysad and we are trying to use FreePBX IP phone setup using BSNL Trunk provider. Which is called LFMT line from BSNL working through DSL line.

Basically, Broadband line connected to our Microtic router with bridge mode setup and then FreePBX installed in a virtual box running on the Debian machine connected through a local network and all our IP Phone connected through our router using a local IP with internal extension which is working fine.

But I am not able to receive or call outside number either a landline or a mobile and I have checked the trunk setup seems to be fine but the register string we need to add username and password with line provider details where i enter those details and apply the configuration which is registering.

So since I am a new learner and I need help to short out this problem if one of you could help that would be really great for me and i am also new to Linux and still learning so kindly help me if anyone has on an idea to solve this issue.

Sorry you are a new learner, but you have set this up in a very challenging way.

Rather than use a custom installation, try setting it up on a cheap old desktop and use the Distro. This will make sure that all of the components (including the operating system components) are correct. Setting the system up in a VM is challenging, and setting the machine up “by hand” makes it even more challenging.

If you are unable to make or receive calls, we can assume that your trunk setup is not fine. That’s what makes inbound and outbound calling work. Important learning note: inbound calling and outbound calling are separate and distinct activities and each has its own setup and debugging steps.

We will need to see the log file around the time that you are trying to connect to your provider. There are many, many things that you could have misapplied. Also, sending us the inbound and outbound trunk configuration settings might be helpful. Your firewall settings are also important, as are your network configuration settings. Obfuscate anything that can specifically identify your setup (IP addresses, usernames, passwords, etc.)

Hello Sir,

Thanks for your response!

Before i used to have the FreePBX installed in cheap and old desktop machine then i had to shift into Virtual Box and one of my friend helped to set up and in the beginning it was working fine even in the Virtual Box I can make a call and receive a call but after sometimes this got into problem.

So Inbound and outbound setups are done correctly so there is no problem for sure but if you still want it to make sure that I can send you the screenshot.

Coming to trunk setup here only i have big doubt since i have username and password config details from provider i try to register that under trunk incoming and outgoing there is option called register string.

So in the register string when i enter the details and save and apply the config then the details should stay in there but its not? its disaper its not shwoing the details which i enter so in my side here something has to be solved since our firwall also configured correctly.

If you could guide me further more to solve it would be really helpfull for me.

When I try to call trunk number its says The number is not registered and when i try to call from the trunk to outside number it’s just engaged.

There is one more thing to make sure my freepbx machine which installed in VB is conecting my local network where i can ping all the computer and the IP phone from the Freepbx machine but i am not able to ping my router IP which is the local gateway also i am not able to ping google or anything?

But i can able to connect Freepbx machine in a web console from the local network do you think this might cause the problem?

Thanking you

Have you checked your gateway ip address on the freepbx box ??
If you can’t ping the router then you can’t get out to the internet … if you can’t get out to the internet then your trunks can’t register.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.