Trunk problem

my carrier provider just support codec g729 I dont know how I can set it on the freepbx when used g729, my Extension get ring but when I pick-up the phone it’s silence. please help me for setting g729.
I use freePBX 2.2.0rc1.

How I can change maint password?

IF you have installed the g729 codec, then it’s simply a matter of adding an allow=g729 statement to the trunk context (probably will need in both incoming and outgoing settings???).

BUT note that due to licensing issues, g729 does not come shipped with Asterisk by default (if it’s installed, it will be in /usr/lib/asterisk/modules. And that is all I will say about that. You might want to pop onto the #freepbx IRC channel if you really need help.

If you mean the maint password that FreePBX complains about, you probably don’t have to worry about it, but if the message bugs you there are two places it has to be changed. One is /etc/asterisk/manager.conf (the “secret =” line) and the other is someplace else I can never remember (but if you can find that same password in a config file somewhere on your system, you know you’ve found it!) :slight_smile:

Trunk setting:

Extension setting:
disallow all
allow g729

with this setting my outbound working but my inbound has problem.
when I make empty on disallow and allow in extension setting my inbound working and outbound has problem. please help me

my DID just support ulaw and my carrier just support g729.

please help me.