Trunk dont register with Vitelity


I had a problem with a Freepbx 13, i had a trunk with vitelity and voipms.

Vitelity is not registering but voipms does.

this server is behind a router but theres no firewall setting blockingas far is i know.

I used other servers inside router and with public ip and i can register vitelity.

i dunno if there´s something more that can block or have to be missconfigured to block register with an specific server.

AFAIK to regsiter you only need user account, pass, ip service and protocol (5060 in this case)

Any info you need or any suggestion would be apreciated.

Thanks in advance

Post your config

Hope this help

AMB to regsiter you only need user account, pass, ip service and protocol (5060 in this case)

The server can ping the other server, theres 2 lines configured the same way with VOIPS without problem

Thanks for replying


I erase user and pass for security4541771

Here is my working config for Vitelity
My incoming user details is blank. All the stuff is in the outgoing tab for me.

General tab:
Trunk name: vitel-inbound

Trunk name: vitel-inbound
Peer details:

Usercontext: your10digitDIDnumber
User details: blank
Register String: username:[email protected]:5060

Are you behind NAT and do you have firewall/NAT rules in regards to port 5060 in place? If so what are they? They error is a timeout which means either Vitelity is not getting your request or the reply to the request is not being received by the PBX.

1 Like

Scratch this.

The problem is only with vitelity , with voipms i can reach receive and make call without problems using the same 5060 port.

Tomorrow im gonna make some changes and test the config u send .

Thanks in advacnce both of you.

I just switched my vitelity inbound trunk to pjsip.

It worked with all the default settings, although I have only used it for 24 hours now.

I was trying to address a problem where I would have to reboot after my network glitched. Otherwise my trunk wouldn’t register.

I had issues with calls to my DID showing NIS. It was my router thinking the link was idle and closed the port. I had to increase my timeout settings in the router to fix it in addition to me config listed above. Adding retry intervals in asterisk as well.

1 Like

PBX Firmware:12.7.5-1807-1.sng7
PBX Service Pack:

Hi, i config another server with freepbx just config that vitelity line , nothing in the network firewall or else changed.

Im stuck with this, dont know where to look or what may cause this

Yep i tried to use pjsip without luck

The funny thing heres is that i change the ip of the server (this had an internal ip not a public) and the vitelity trunk start to work

Thanks everyone for the help!!! :slight_smile:

Did you try pjsip?

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.