Trunk callerID provider (dialplan)

Hello !

since two days i’m digging in all extensions.conf to find where the outbound callernumber is set.

I have a WebRTC softphone and i’m calling a random smartphone => The number “+33972XXXX21” appear.
I wanted to know where this number is set in the dialplan, to modify it in te dialplan with a custom one.

Thanks by advance !

I already tried to change all
“Set(CALLERID(x))” options.

But no luck still the same number appear on my smartphone.


If this number is yours, bundled with your internet service from Orange, SFR, Free or Bouygues, you have no control over your outbound caller ID and will need to get service from another provider to do this.

If it’s with a different trunking provider, you need to set up the trunk to put the caller ID in the correct header and proper format. There may still be restrictions; for example if you are trying to send the original caller’s number when forwarding to your mobile, some providers don’t allow that. Let us know who the provider is and we can probably help.

If the +339 number is not yours and you are trying to send a number that is outside the EEA but calling a mobile number within the EEA, your provider is likely sending a fake France caller ID to take advantage of low tariffs (enforced by the guys in Belgium) regarding calls within Europe. You can either use another provider (and probably pay more for the call), or get a number in Europe that you can send with those calls.

This is my number from a basic OVH trunk sip

I want my webRTC softphone to send a wanted callerid to my asterisk server during a call. With this data the number that appear on a smartphone or whatever else will be the callerid set with the webRTC.

i already receive the wanted callerid correctly. But now i don’t know how to change this.

(The number “+339” should be the number set on the webRTC)

Can you tell me what provider is good for me?

Thank you for your reply,

I think OVH give me 0 control of the callerID

What provider should i use??

I want a trunk SIP provider that able me to modify the callerID the way i want.

Thank you for your reply,

Depends - where are you?

France @cynjut

Do you know a good provider that able to do that ?

Can someone tell me more about providers and CallerID ?

I tried to do
exten => s,1,Set(CALLERID(num)=+337XXXXXX)

but the number is still the same.
I don’t know how this work.

Let’s talk about how Caller ID gets set - perhaps you’ll get why that is a hard question:

There are several places where Caller ID can be set for an outbound call:

  1. If you are using a Softphone, you can set the Caller ID in the phone itself. Most “hard” phones don’t do this - they rely on Level 2. EIther way, level 2 can override this option.

  2. Your extension configuration can set the phone’s Caller ID. This is handy for places where the individual phone decides what the output CID should be. For example, if you want “COMPANY BILLING” to show up in your CID, you set that at the Extension level. It could be overridden by Level 3.

  3. Your Outbound Routes have the option of setting and overriding all calls that match that Outbound Route. This can be handy for a bunch of different things. Like all the rest, it can be overridden by Level 4.

  4. Your Trunk has the option of setting and overriding all calls through that particular trunk. This isn’t as handy as one would hope, since it messes with FMFM, but other than that, if you need it, you have it. It is kind of nice for “home phone” networks. Like the others, it can be overridden by Level 5.

  5. Your provider may completely ignore all of that and set the Caller ID for you to whatever they want.

As if that wasn’t enough fun, sometimes your calls will get identified using the CNAME set for your phone number in the CNAME database your provider uses.

Now that you know all of the places you and other people can mess with your Caller ID, the only way to know which is setting the final CID is to look through the logs and to understand that you might not be getting a vote in the first place.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.