Troubleshooting Echo

I realize there’s a bunch of threads related to eliminating echo. Here’s my scenerio:

I have an AEX800 card, 8 fxo lines (only 4 currently in use).

I have echo issues on some calls, but not others - seems to be no rhyme or reason. I tried shutting down asterisk (amportal stop) and running FXOTUNE -i, but it generates an error:

/dev/dahdi/0 absent: No such file or directory
/dev/dahdi/1 absent: No such file or directory
/dev/dahdi/2 absent: No such file or directory

This counts all the way up to /dev/dahdi/242

My understanding is that in order for MG2 to work properly, that command needs to run.

I’m a bit at a loss right now - almost ready to fork out the money for a Digium HW echo card.

I guess before I get asked to do this, here are some command outputs:

Span 1: WCTDM/0 “Wildcard AEX800” (MASTER)

1 FXO FXSKS (In use) (EC: MG2 - INACTIVE)
2 FXO FXSKS (In use) (EC: MG2 - INACTIVE)
3 FXO FXSKS (In use) (EC: MG2 - INACTIVE) RED
4 FXO FXSKS (In use) (EC: MG2 - INACTIVE)
5 FXO FXSKS (In use) (EC: MG2 - INACTIVE) RED
6 FXO FXSKS (In use) (EC: MG2 - INACTIVE) RED
7 FXO FXSKS (In use) (EC: MG2 - INACTIVE) RED
8 FXO FXSKS (In use) (EC: MG2 - INACTIVE) RED

And there’s this

[[email protected] ~]# dahdi_cfg -vvv
DAHDI Tools Version - 2.6.1

DAHDI Version: 2.6.1
Echo Canceller(s): HWEC, MG2
Configuration

Channel map:

Channel 01: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 01)
Channel 02: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 02)
Channel 03: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 03)
Channel 04: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 04)
Channel 05: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 05)
Channel 06: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 06)
Channel 07: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 07)
Channel 08: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 08)

8 channels to configure.

Setting echocan for channel 1 to mg2
Setting echocan for channel 2 to mg2
Setting echocan for channel 3 to mg2
Setting echocan for channel 4 to mg2
Setting echocan for channel 5 to mg2
Setting echocan for channel 6 to mg2
Setting echocan for channel 7 to mg2
Setting echocan for channel 8 to mg2

Hope that helps :slight_smile:

K, upon some further digging I ran the following commands

#asterisk stop


#fxotune -i -n 4 -e 4 -p

Then I restarted the box, and got the results I wanted in the console. Now to do an echo test.