Trouble with voicemail - emails aren't going out

Hi,

Software and system info

  • FreePBX v2.3.0RC1.1
  • voicemail module v2.0.3.2
  • Asterisk 1.4.10
  • CentOS 4.5
  • sendmail, which listens to connections from localhost on port 25 (unauth) and 587 (auth). It’s using a smarthost to relay mail. Other functions on the same machine (e.g. the hourly errors from the amportal cron job) reliably generate emails that are sent as expected.

Unfortunately, I can’t seem to convince FreePBX/Asterisk to send me voicemails as email attachments. e.g. extension 100 has “Voicemail & Directory Status” set to “Enabled”, the voicemail password is set to one that works via the phone, the email address is valid ([email protected]), “email attachment” is set to “yes”, and yet the voicemail email attachment is never sent. I can check the voicemail via the web ARI and via the phone interface, but like I said, no email. The sendmail logs indicate that nothing is attempting to connect when Asterisk should be sending the email.

Also, I created a brand new extension just for testing this and had the same results. The voicemail was recorded and is accessible via the phone interface, but there’s no attempt to send it via email.

This used to work with a recent FreePBX beta - I’m not sure when exactly it stopped.

Any suggestions? Otherwise, things are working well, but I’d really like to get this going again. )

Here are a few sanitized yet relevant lines from /var/log/asterisk/full

[…begin quote…]

[Aug 8 234733] VERBOSE[30667] logger.c – Executing [[email protected]] VoiceMail(“SIP/100-[elided]”, “[email protected]|b”) in new stack
[Aug 8 234733] VERBOSE[30667] logger.c – <SIP/100-[elided]> Playing ‘/var/spool/asterisk/voicemail/default/100/greet’ (language ‘en’)
[Aug 8 234735] VERBOSE[30667] logger.c – <SIP/100-[elided]> Playing ‘vm-isonphone’ (language ‘en’)
[Aug 8 234736] VERBOSE[30667] logger.c – <SIP/100-[elided]> Playing ‘vm-intro’ (language ‘en’)
[Aug 8 234742] VERBOSE[30667] logger.c – <SIP/100-[elided]> Playing ‘beep’ (language ‘en’)
[Aug 8 234742] VERBOSE[30667] logger.c – Recording the message
[Aug 8 234742] VERBOSE[30667] logger.c – x=0, open writing /var/spool/asterisk/voicemail/default/100/tmp/hnAcpJ format wav49, 0x96b0290
[Aug 8 234742] VERBOSE[30667] logger.c – x=1, open writing /var/spool/asterisk/voicemail/default/100/tmp/hnAcpJ format gsm, 0x9706348
[Aug 8 234742] VERBOSE[30667] logger.c – x=2, open writing /var/spool/asterisk/voicemail/default/100/tmp/hnAcpJ format wav, 0x974c4c8
[Aug 8 234750] VERBOSE[30667] logger.c – User ended message by pressing #
[Aug 8 234750] VERBOSE[30667] logger.c – <SIP/100-[elided]> Playing ‘auth-thankyou’ (language ‘en’)
[Aug 8 234750] DEBUG[30667] app_macro.c Executed application Voicemail
[Aug 8 234750] VERBOSE[30667] logger.c – Executing [[email protected]] Goto(“SIP/100-[elided]”, “exit-SUCCESS|1”) in new stack
[Aug 8 234750] VERBOSE[30667] logger.c – Goto (macro-vm,exit-SUCCESS,1)
[Aug 8 234750] DEBUG[30667] app_macro.c Executed application Goto
[Aug 8 234750] VERBOSE[30667] logger.c – Executing [[email protected]] Playback(“SIP/100-[elided]”, “goodbye”) in new stack
[Aug 8 234750] VERBOSE[30667] logger.c – <SIP/100-[elided]> Playing ‘goodbye’ (language ‘en’)
[Aug 8 234751] DEBUG[30667] app_macro.c Executed application Playback
[Aug 8 234751] VERBOSE[30667] logger.c – Executing [[email protected]] Hangup(“SIP/100-[elided]”, “”) in new stack
[Aug 8 234751] VERBOSE[30667] logger.c == Spawn extension (macro-vm, exit-SUCCESS, 2) exited non-zero on ‘SIP/100-[elided]’ in macro ‘vm’
[Aug 8 234751] VERBOSE[30667] logger.c == Spawn extension (macro-vm, exit-SUCCESS, 2) exited non-zero on ‘SIP/100-[elided]’ in macro ‘exten-vm’
[Aug 8 234751] VERBOSE[30667] logger.c == Spawn extension (macro-vm, exit-SUCCESS, 2) exited non-zero on ‘SIP/100-[elided]’
[Aug 8 234751] DEBUG[30667] cdr_addon_mysql.c cdr_mysql inserting a CDR record.
[Aug 8 234751] DEBUG[30667] cdr_addon_mysql.c cdr_mysql SQL command as follows INSERT INTO cdr (calldate,clid,src,dst,dcontext,channel,dstchannel,lastapp,lastdata,duration,billsec,disposition,amaflags,accountcode) VALUES (‘2007-08-08 234718’,’“Graham” <100>’,‘100’,‘100’,‘ext-local’, ‘SIP/100-[elided]’,‘SIP/100-[elided]’,‘Hangup’,’’,33,18,‘ANSWERED’,3,’’)

[…end quote…]

(Note that I was calling my own extension to leave this test voicemail. It arrived in my voicemail box, but no email.)

thanks,

Graham

Have you checked the mail logs?

Yep. There’s activity, but nothing from Asterisk or FreePBX. No connection attempts, no mail relay attempts, etc.

However, if I ‘telnet localhost 25’, I’m immediately given the Sendmail banner message, and my connection shows up in the logs. So, if it was trying to send locally, it could. And, remember that other things on the same host have no trouble sending email.

thanks,

Graham

have you configured the extension to send email and checked the voicemail.conf file to make sure it is being properly written. Asterisk does the email sending, not FreePBX.

Hi,

Yes, to both questions.

I acknowledge that Asterisk does the email sending, but FreePBX is supposed to configure Asterisk. ) Until now, I’ve only used FreePBX to configure this Asterisk installation - it’s only this voicemail issue that has prompted me to edit the config files directly on this installation.

Now’s probably a good time to point out that I love FreePBX and sincerely appreciate your efforts. It’s making it much easier for me to dive into the world of VOIP PBXes, with Asterisk in particular.

But I sure wish I could figure out this voicemail-to-email issue. )

Graham

Hi

I am having the same problem only since I updated to FreePBX v2.3.0RC1.1 would love a fix on this. And I also Love Freepbx
Lee

2.3.0rc1.1 is a beta release with many bugs that have been fixed in the 2.3.0.x and 32.3.1.0 releases.

You can find complete information on this site under the download tab above.

Hi Graham…

I am having the same problem that you mention in your post. I can send mail directly from Linux System, but Asterisk does not send the attach voicemail by e-mail.

Did you could solve the problem …, if so, could you help me with this issue…

I have installed:

Asterisk 1.4.17
FreePBX 2.3.1.3
exim
Debian each

Thanks in advance for your help…

Luis

This is the same problem I’m having. Has anyone found a solution?

Asterisk 1.2.23
FreePBX 2.3.1.5

FreePBX writes voicemail changes to the /etc/asterisk/voicemail.conf file. Take a look at that file first to see if your emails are set there. As for my system, I had similar issues but it was resolved when I set up smtp relay (I used webmin for that).

The info in the conf file looks right, but where did you go to set the smtp relay? I haven’t seen anything in webmin for that.

Update: I’m getting an error in my mail.log file that says: warning: Illegal address syntax from my.server.org[xx.x.x.xx] in MAIL command: [email protected]?c

Anyone have an idea what may be causing this?

Being a rookie, I have a trixbox 2.4.0 box configured and working great except voicemails are not being sent to Email. Would anyone have a step by step guide to setting up sendmail?

Try http://www.trixbox.org/wiki/sendmail-voicemail

My voicemail to email works…

That is until I edit the voicemail.conf. I changed the SERVERMAIL = line
by default it said servermail = [email protected]
I changed it to [email protected]
after that - emails no longer came through. Changing it back to the default worked just fine.
I just have ‘spam’ problems with the default formatting.

Any hints?