Trouble with VM's and SoftPhones

I have 3 test machines with FreePBX distro 10.13.66 x64 installed.

One is a standard PC loaded directly, one is a Win7 machine running
VMWare and the other one is a Win 7 system running VirtualBox.

Both my VM machine have Bridged Network Adapter setups and both
exhibit the same symptoms, so I will just refer to these as the VM
These machine are always booted in isolation to each other for test purposes.
All machines are set with the same static network configurations.

On my native Linux machine everything works and I can connect to them
from other Windows machines and register X-lite Softphones.

On the VM machines, I can connect with HTTP via a browser, or by
Putty to the console and all appears to work well until I try and
register X-lite softphones. These always fail with a 408 or 503 error. I
have tried with and without Proxy’s configured in X-Lite but it makes
no difference.

Additional info.
I can ping in and out of all machines.
The VM host machine does not have any Firewalls or AVS turned on.
VM hosts report their main NIC’s and also either a VMWare or VirtualBox
Host-Only adapter as well as the standard Tunnel adapters. I have tried
using the Host-Only IP’s as the Proxy’s in X-Lite but it also did not
No additional info is shown in the logs when X-Lite tries to
connect so I am assuming that its messages are not being received by the
Linux Guests on the VM machines.

Please can anyone advise how I configure this to work on the VM machines as I want to test with SIP trunks next.


If you do asterisk -rvvvv on any of the VM’s do you see any attempts from the X-Lite phone trying to connect in any way? If not there is something not allowing the connection. Host Only will not work as that is just network between host and VM and nothing else. If it is bridged mode then it’s just like plugging the VM into your network so that really should work. The VM is configured with an IP in the same schema as the computer with X-Lite?

Thanks Jlinkcom…

I ran wireshark on this and was just seeing a Destination Unreachable (Port Unreachable) error when X-Lite tried to register. I then tried a 2 network (NAT and Host-Only) setup I read about on another forum… it didnt work.

Out of desperation, I put everything back to how it was… a single bridged network and deleted all users and extensions. I created another new extension… and it registered first time.

I have no idea why this should work, but it has so thanks for your help.