Trouble with calendar-based find me/follow me

Hello. I’m using FreePBX 14 distro. Couple of days ago I tried to set up calendar matching find me/follow me. It seemed rather easy. I.e. I want to redirect calls on saturdays. So I created a calendar with test event, then configured an extension as on a screenshot attached.

But it doesn’t work. In console I see

– Executing [[email protected]:1] AGI(“SIP/6666-00008505”, “calendar.agi,calendar,integer,f5189002-2efe-4719-ac7f-7d9dbbde564c,Europe/Moscow”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/calendar.agi
calendar.agi,calendar,integer,f5189002-2efe-4719-ac7f-7d9dbbde564c,Europe/Moscow: Setting Timezone To: Europe/Moscow
calendar.agi,calendar,integer,f5189002-2efe-4719-ac7f-7d9dbbde564c,Europe/Moscow: Checking Calendar
calendar.agi,calendar,integer,f5189002-2efe-4719-ac7f-7d9dbbde564c,Europe/Moscow: Calendar: True
calendar.agi,calendar,integer,f5189002-2efe-4719-ac7f-7d9dbbde564c,Europe/Moscow: Setting CALENDAR to:1
– <SIP/6666-00008505>AGI Script calendar.agi completed, returning 0
– Executing [[email protected]:2] GotoIf(“SIP/6666-00008505”, “1?ext-local,6164,1”) in new stack
– Goto (ext-local,6164,1)

So, it is just goes to dial 6164, instead of followme-check and then dial 6167.
What am I doing wrong?

Hello? Is there anybody? :slight_smile:

We’re here. I just don’t have a clue. For whatever reason (and there’s no time context for us, so it’s hard to say) but it looks like your calendar returned “True”, then set the Calendar event to ‘1’. In the step at from-internal,2, the GotoIf sees a value of ‘1’ and takes the ‘false’ leg.

I’d submit a ticket for this. It’s a little opaque to us in the user community, so it might be time for the pros to see it.

Anyway thanks for response :slight_smile:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.