Trouble updating

I am having some problems when I run yum update:

[[email protected] ~]# yum update
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package asterisk18.i386 0:1.8.5.0-1_centos5 set to be updated
---> Package asterisk18-addons.i386 0:1.8.5.0-1_centos5 set to be updated
---> Package asterisk18-addons-bluetooth.i386 0:1.8.5.0-1_centos5 set to be updated
---> Package asterisk18-addons-core.i386 0:1.8.5.0-1_centos5 set to be updated
---> Package asterisk18-addons-mysql.i386 0:1.8.5.0-1_centos5 set to be updated
---> Package asterisk18-addons-ooh323.i386 0:1.8.5.0-1_centos5 set to be updated
---> Package asterisk18-core.i386 0:1.8.5.0-1_centos5 set to be updated
--> Processing Dependency: libspeex.so.1 for package: asterisk18-core
--> Processing Dependency: libspeexdsp.so.1 for package: asterisk18-core
---> Package asterisk18-curl.i386 0:1.8.5.0-1_centos5 set to be updated
---> Package asterisk18-dahdi.i386 0:1.8.5.0-1_centos5 set to be updated
---> Package asterisk18-doc.i386 0:1.8.5.0-1_centos5 set to be updated
---> Package asterisk18-voicemail.i386 0:1.8.5.0-1_centos5 set to be updated
---> Package libpri.i386 0:1.4.12-1_centos5 set to be updated
---> Package libpri-debuginfo.i386 0:1.4.12-1_centos5 set to be updated
---> Package libpri-devel.i386 0:1.4.12-1_centos5 set to be updated
--> Running transaction check
---> Package speex.i386 0:1.2-0.11.rc1.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================================================================================================================
 Package                                                  Arch                              Version                                           Repository                        Size
=====================================================================================================================================================================================
Updating:
 asterisk18                                               i386                              1.8.5.0-1_centos5                                 pbx                              4.0 k
 asterisk18-addons                                        i386                              1.8.5.0-1_centos5                                 pbx                              3.3 k
 asterisk18-addons-bluetooth                              i386                              1.8.5.0-1_centos5                                 pbx                              142 k
 asterisk18-addons-core                                   i386                              1.8.5.0-1_centos5                                 pbx                              287 k
 asterisk18-addons-mysql                                  i386                              1.8.5.0-1_centos5                                 pbx                              270 k
 asterisk18-addons-ooh323                                 i386                              1.8.5.0-1_centos5                                 pbx                              2.8 M
 asterisk18-core                                          i386                              1.8.5.0-1_centos5                                 pbx                               21 M
 asterisk18-curl                                          i386                              1.8.5.0-1_centos5                                 pbx                              188 k
 asterisk18-dahdi                                         i386                              1.8.5.0-1_centos5                                 pbx                              1.2 M
 asterisk18-doc                                           i386                              1.8.5.0-1_centos5                                 pbx                               11 k
 asterisk18-voicemail                                     i386                              1.8.5.0-1_centos5                                 pbx                              237 k
 libpri                                                   i386                              1.4.12-1_centos5                                  pbx                              168 k
 libpri-debuginfo                                         i386                              1.4.12-1_centos5                                  pbx                              635 k
 libpri-devel                                             i386                              1.4.12-1_centos5                                  pbx                              230 k
Installing for dependencies:
 speex                                                    i386                              1.2-0.11.rc1.el5                                  pbx                               96 k

Transaction Summary
=====================================================================================================================================================================================
Install       1 Package(s)
Upgrade      14 Package(s)

Total size: 28 M
Total download size: 5.4 M
Is this ok [y/N]: y
Downloading Packages:
(1/9): asterisk18-addons-1.8.5.0-1_centos5.i386.rpm                                                                                                           | 3.3 kB     00:00
http://yum.freepbxdistro.org/pbx/1.8.x.x/i386/RPMS/digium/asterisk/1.8/1.8.5.0-1/asterisk18-1.8.5.0-1_centos5.i386.rpm: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://yum.freepbxdistro.org/pbx/1.8.x.x/i386/RPMS/speex/speex-1.2-0.11.rc1.el5.i386.rpm: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://yum.freepbxdistro.org/pbx/1.8.x.x/i386/RPMS/digium/libpri/1.4.12-1/libpri-1.4.12-1_centos5.i386.rpm: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
(5/9): libpri-devel-1.4.12-1_centos5.i386.rpm                                                                                                                 | 230 kB     00:00
http://yum.freepbxdistro.org/pbx/1.8.x.x/i386/RPMS/digium/asterisk/1.8/1.8.5.0-1/asterisk18-voicemail-1.8.5.0-1_centos5.i386.rpm: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://yum.freepbxdistro.org/pbx/1.8.x.x/i386/RPMS/digium/libpri/1.4.12-1/libpri-debuginfo-1.4.12-1_centos5.i386.rpm: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://yum.freepbxdistro.org/pbx/1.8.x.x/i386/RPMS/digium/asterisk/1.8/1.8.5.0-1/asterisk18-dahdi-1.8.5.0-1_centos5.i386.rpm: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
(9/9): asterisk18-addons-ooh323-1.8.5.0-1_centos5.i386.rpm                                                                                                    | 2.8 MB     00:03


Error Downloading Packages:
  libpri-1.4.12-1_centos5.i386: failure: RPMS/digium/libpri/1.4.12-1/libpri-1.4.12-1_centos5.i386.rpm from pbx: [Errno 256] No more mirrors to try.
  asterisk18-voicemail-1.8.5.0-1_centos5.i386: failure: RPMS/digium/asterisk/1.8/1.8.5.0-1/asterisk18-voicemail-1.8.5.0-1_centos5.i386.rpm from pbx: [Errno 256] No more mirrors to try.
  asterisk18-1.8.5.0-1_centos5.i386: failure: RPMS/digium/asterisk/1.8/1.8.5.0-1/asterisk18-1.8.5.0-1_centos5.i386.rpm from pbx: [Errno 256] No more mirrors to try.
  speex-1.2-0.11.rc1.el5.i386: failure: RPMS/speex/speex-1.2-0.11.rc1.el5.i386.rpm from pbx: [Errno 256] No more mirrors to try.
  asterisk18-dahdi-1.8.5.0-1_centos5.i386: failure: RPMS/digium/asterisk/1.8/1.8.5.0-1/asterisk18-dahdi-1.8.5.0-1_centos5.i386.rpm from pbx: [Errno 256] No more mirrors to try.
  libpri-debuginfo-1.4.12-1_centos5.i386: failure: RPMS/digium/libpri/1.4.12-1/libpri-debuginfo-1.4.12-1_centos5.i386.rpm from pbx: [Errno 256] No more mirrors to try.

I’m getting 404’s on the respected files, but if I pull them up in a web browser I can see them there, so this is strange. I did issue a yum clean all to rebuild the package cache, but it didn’t help.

Anyone have any ideas? I’m not real familiar with yum and it’s oddities… I’m a Debian man :slight_smile:

Yes we are in the progress of syncing the yum servers. It started last night but we had also pulled down Centos 6.0 to start playing with that and the sync is talking alot longer than we thought.