Trouble setting up AJAM for freepbx/asterisk

Not sure if this is the right place to post this, but…

I am having trouble setting up AJAM for remote api manager access. I have made the changes to http.conf and manager.conf, reloaded asterisk but I am still unable to access api manager.

Below are my config files, and the http show output from cli.


enabled = yes
port = 5038
bindaddr =
displayconnects=no ;only effects 1.6+

secret = amp111
read = system,call,log,verbose,command,agent,user,config,command,dtmf,reporting,cdr,dialplan,originate
write = system,call,log,verbose,command,agent,user,config,command,dtmf,reporting,cdr,dialplan,originate
writetimeout = 5000

#include manager_additional.conf
#include manager_custom.conf


[general] enabled=yes enablestatic=yes bindaddr= bindport=8088 prefix=asterisk

http show status (CLI)

HTTP Server Status:
Prefix: /asterisk
Server Enabled and Bound to

Enabled URI's:
/asterisk/httpstatus => Asterisk HTTP General Status
/asterisk/phoneprov/... => Asterisk HTTP Phone Provisioning Tool
/asterisk/static/... => Asterisk HTTP Static Delivery
/asterisk/ws => Asterisk HTTP WebSocket

Enabled Redirects:

Shouldn’t I see /asterisk/manager in the URI’s among others? Can someone point me in the right direction?

Asterisk Version is: Asterisk 11.11.0 on a x86_64 running Linux
Freepbx: FreePBX

Below is what I get when I go to the http status page

In the [general] section of manager.conf you need:

Then restart Asterisk. Test by browsing to:

Woops, thanks lgaetz. I was able to access the demo page, login in and it looks like it’s working. However, I still don’t have the manager page.

Ultimately I want to be able to issue commands like http://localhost:8088/manager?action=login&username=foo&secret=bar

EDIT: Scratch that, I was wrong, that definitely worked. Thanks again.