Trouble installing SpanDSP

I’m hitting roadblock after roadblock trying to install and configure SpanDSP on my system. I already installed the res_fax_digium module but from testing the faxing the quality isn’t good. It shrinks the page. After contacting the support for Schmooze’s fax pro they told me that the digium fax module has caused issues and they suggest using SpanDSP. But I am tearing my hair out trying to get SpanDSP installed.

I tried using the instructions at
But that had several dead links for app_rxfax.c, app_txfax.c, and app_nv_faxdetect.c so I couldn’t get it installed from that.

I tried using this site
But, again, I couldn’t find the files app_rxfax.c, app_txfax.c, and apps_makefile.patch

I then tried using the instructions here
Those instructions are very vague and even when following them the install didn’t perform as the instructions said it would.

Any idea what I can do to get this installed? Are there any better tutorials out there?

The FreePBX Distro, and the latest versions of AsteriskNow should have SpandDSP already installed.

I am using AsteriskNOW (installed in early 2013) and I’m on Asterisk 11.14 and FreePBX 12.0.11 but I don’t have SpanDSP. When I remove the module I had installed I still get the following error in the fax section of my extension set-up

ERROR: No FAX modules detected!
Fax-related dialplan will NOT be generated.
This module requires Fax for Asterisk ( or spandsp based app_fax ( to function.

Do I need to do something to update my AsteriskNOW install with SpanDSP?

So, after researching some of this, as well as for some other reasons, I’m thinking about doing a clean install on a new system using FreePBX Distro. If I do that, will I need to reconfigure the entire system again? Or could I export my current FreePBX settings and install on the new distro? What about my commercial modules (fax pro and conference pro) will I be able to move them? Does the distro come complete with SpanDSP for faxing?


Ok, I’m now completely confused. is AsteriskNOW and FreePBX distro the same thing? The uprgade page for AsteriskNOW takes me to a page about FreePBX distro

I can’t even find out what AsteriskNOW version I have. My version doesn’t even show up in the system admin

When did you install it?

Early 2013. I think I’m just going to rebuild using the FreePBX distro. I need to build a more scalable system anyways.

Yes, that version would not have included SpanDSP, the latest versions of AstriskNow do.

It was installed the first part of 2013.