Trouble Getting Zero Touch to Work

Having some issues getting Zero Touch configuration to work when provisioning a new phone. First, in freePBX, I create a new extension, then in End Point Manager/Extension Mapping I create a map for the new extension w/ the new phone’s MAC.

Next I add the phone to the account at sangoma’s portal via the phone’s MAC address.

Then I change the redirect to ‘enabled,’ then type is ‘deployment’ and I match the appropriate location.

At this point I assumed once I plugged the phone into the network Zero Touch would take over the setup and retrieve the proper configuration. However, when first booting the phone it cannot find a server. At this point I would have to choose a manual setup and it does work from there.

What steps am I missing to get ZT to work?

The phone(s) I’m using for this setup are Sangoma P325 & P330


Hi @dbatten10x
Maybe you have to check below settings.
1st - Firewall → Service → Extra Service ( Allow HTTP or HTTPS ) HTTP Provisioning

2nd- Endpoint Manager → Global Settings ( check your Server IP Addresses )

3rd- EPM → Brands → Sangoma → S&P Phone → Your ZERO Template → Edit ( check Provisioning Address and Provisioning Protocol )

4rd - Sangoma Portal → PBX’s → ID of your PBX → Phones Tab Fill Phone Zero touch infos.

5th- Make Factory Reset of your Phone.

He’s setting up P-series phones.

I have only seen P-series phones work with Zero Touch if you provision by DPMA. So make sure DPMA is enabled in EPM and the Sangoma Portal redirection settings point to your PBX’s (PJ)SIP port.

The phone uses the details for the deployment which means that the Phones tab for the deployment must be correctly configured with DPMA settings for your PBX.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.