Trouble configuring remote phone with RentPBX

Hi

I am fairly new to this whole world and am having a problem.

I have a server set up at RENTPBX with the latest version of asterisk/freepbx (version 11 on both).
I opened up all the usual ports on the RentPBX side.

I Loaded a SIPphone on my computer and also plugged in an Aastra 6739i phone into my network.
I can get the aastra phone to call the siphone but I cannot get the Sipphone to connect to the aastra phone. I have put the aastra phone into DMZ just to see if its a problem with my firewall but that hasn’t changed anything.

The log on the phone side says

1 [email protected]:5060 Registered

but when I do Sip Show Registry on the server it says
nothing is registered.

when I do sip show peers I get

Name/username Host Dyn Forcerport ACL Port Status Description
701/701 (Unspecified) D A 0 UNKNOWN
703/703 192.168.1.9 D A 5060 UNREACHABLE
710/710 71.190.204.64 D A 1025 OK (19 ms)
3 sip peers [Monitored: 1 online, 2 offline Unmonitored: 0 online, 0 offline]

Here is also a section of my Asterisk Log

– Executing [[email protected]:40] Set(“SIP/710-00000043”, “CONNECTEDLINE(num)=703”) in new stack
– Executing [[email protected]:41] Set(“SIP/710-00000043”, “D_OPTIONS=TtrI”) in new stack
[-- Executing [[email protected]:42] Dial(“SIP/710-00000043”, “SIP/703,TtrI”) in new stack
Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)
= Everyone is busy/congested at this time (1:0/0/1)
: – Executing [[email protected]:43] ExecIf(“SIP/710-00000043”, “0?MacroExit()”) in new stack
– Executing [[email protected]:44] ExecIf(“SIP/710-00000043”, “0?Set(DIALSTATUS=)”) in new stack
– Executing [[email protected]:45] GosubIf(“SIP/710-00000043”, “0?s-CHANUNAVAIL,1()”) in new stack
– Executing [[email protected]:46] MacroExit(“SIP/710-00000043”, “”) in new stack
– Executing [[email protected]:15] Set(“SIP/710-00000043”, “SV_DIALSTATUS=CHANUNAVAIL”) in new stack
– Executing [[email protected]:16] GosubIf(“SIP/710-00000043”, “0?docfu,1()”) in new stack
– Executing [[email protected]:17] GosubIf(“SIP/710-00000043”, “0?docfb,1()”) in new stack
– Executing [[email protected]:18] Set(“SIP/710-00000043”, “DIALSTATUS=CHANUNAVAIL”) in new stack
– Executing [[email protected]:19] ExecIf(“SIP/710-00000043”, “0?MacroExit()”) in new stack
– Executing [[email protected]:20] GotoIf(“SIP/710-00000043”, “1?s-CHANUNAVAIL,1”) in new stack
– Goto (macro-exten-vm,s-CHANUNAVAIL,1)
– Executing [[email protected]:1] GotoIf(“SIP/710-00000043”, “0?exit,1”) in new stack
– Executing [[email protected]:2] PlayTones(“SIP/710-00000043”, “congestion”) in new stack
– Executing [[email protected]:3] Congestion(“SIP/710-00000043”, “10”) in new stack
== Spawn extension (macro-exten-vm, s-CHANUNAVAIL, 3) exited non-zero on ‘SIP/710-00000043’ in macro ‘exten-vm’
== Spawn extension (from-internal, 703, 2) exited non-zero on ‘SIP/710-00000043’
– Executing [[email protected]:1] Hangup(“SIP/710-00000043”, “”) in new stack
– Unregistered SIP ‘703’
– Registered SIP ‘703’ at 192.168.1.9:5060

any suggestions would be appreciated.

Thasnks

It is hard to say as you do not ID which extension is what. It might be better to do a ‘sip show peer XXX’ with XXX being the ext #. Do it for both extensions and post that.

Also, on a stock FreePBX hosted ( on RentPBX) you should not have to touch the firewall. SIP and Media ports should be open. If you mucked about with it… that could be the source of the issue. More likely issue with Asterisk SIP Settings, check to see that it is set for a static IP.