Trouble configuring FreePBX for stereo recordings

Hi. I am using FreePBX 2.10 with Asterisk 11.4 on CentOS 6.1.

As it stands, the configuration that is being generated by FreePBX is using MixMonitor to record the calls. This results in a single, mono channel audio file being generated and saved.

However, I need to have both audio channels (caller and recipient) kept separately, with the end goal of having a single, stereo sound file, with each speaker having their own channel.

Reading around, I believe this might be possible using Monitor to record the sound files instead of MixMonitor, where Monitor would record each channel as a separate sound file, and then call a custom defined script which would handle merging them into a stereo file.

The problem is, I cannot find any way to turn MixMonitor off in FreePBX. The config defining the use of MixMonitor seems to be getting auto-generated by FreePBX into

While it MIGHT be possible for me to hack the conf file manually to use Monitor instead, any manual changes would get blown away the next time FreePBX regenerates the file.

The only reference I could find to MixMonitor in the GUI was under
Settings->Advanced Settings->Queues Module->Use MixMonitor for Recordings
Changing this option to False and applying the config didn’t result in any success, as all call recordings as still coming out as single mono, and the extensions_additional.conf file still contains config to use MixMonitor instead of Monitor.

If anyone has any advice about how or even if I can use the GUI to achieve what I’m trying to do it would be appreciated. And if I can’t use the GUI, any alternative suggestions are very welcomed.

1 Like

Any ideas? Or is this something that just isn’t possible in FreePBX at the moment?