Translate.c:341 Warning, NCH Dial Dictate drops call, RTP timeout same subnet, translation error?

Hello, I’ve installed a trial of NCH Dial Dictate and added a standard extension for it. The extension registers and calls to the extension work; two way audio, DTMF everything works as expected. The problem is that after 30 seconds of no DTMF sent (ie; recording a dictation) the call drops. If I continue to send DTMF by pressing numbers the call continues forever. When the call drops the asterisk console sends this error:

[2015-11-17 11:59:55] NOTICE[1792]: chan_sip.c:29212 check_rtp_timeout: Disconnecting call ‘SIP/8040-000000ae’ for lack of RTP activity in 31 seconds

Whenever DTMF is sent I recieve the following error on the console:

[2015-11-17 11:59:24] WARNING[30184][C-000000ad]: translate.c:341 framein: no samples for gsmtolin

I have googled my brains out and I cannot figure out for the life of me what gsmtolin is, If I change call quality in dial dicate I can use alaw ulaw or gsm. Regardless of the codec I chose this error is prepended with tolin; for example gsmtolin, alawtolin or ulawtolin.

This is the full progression of the call as reported by the asterisk console:

== Using SIP VIDEO TOS bits 136
== Using SIP VIDEO CoS mark 6
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called SIP/8040
– Connected line update to SIP/8007-000000ad prevented.
– SIP/8040-000000ae is ringing
– SIP/8040-000000ae is ringing
– Connected line update to SIP/8007-000000ad prevented.
– SIP/8040-000000ae answered SIP/8007-000000ad
> 0x7f3b90036860 – Probation passed - setting RTP source address to 192.168.1.166:8000
> 0x7f3ba0034d60 – Probation passed - setting RTP source address to 192.168.1.154:2252
[2015-11-17 11:59:11] WARNING[30184][C-000000ad]: translate.c:341 framein: no samples for gsmtolin
[2015-11-17 11:59:20] WARNING[30184][C-000000ad]: translate.c:341 framein: no samples for gsmtolin
[2015-11-17 11:59:24] WARNING[30184][C-000000ad]: translate.c:341 framein: no samples for gsmtolin
[2015-11-17 11:59:24] WARNING[30184][C-000000ad]: translate.c:341 framein: no samples for gsmtolin
[2015-11-17 11:59:55] NOTICE[1792]: chan_sip.c:29212 check_rtp_timeout: Disconnecting call ‘SIP/8040-000000ae’ for lack of RTP activity in 31 seconds
– Executing [[email protected]:1] Macro(“SIP/8007-000000ad”, “hangupcall,”) in new stack
– Executing [[email protected]:1] ExecIf(“SIP/8007-000000ad”, “0?Set(CDR(recordingfile)=internal-8040-8007-20151117-115906-1447783146.174.wav)”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/8007-000000ad”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,4)
– Executing [[email protected]:4] Hangup(“SIP/8007-000000ad”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/8007-000000ad’ in macro ‘hangupcall’
== Spawn extension (macro-dial-one, h, 1) exited non-zero on ‘SIP/8007-000000ad’
== Spawn extension (macro-dial-one, s, 44) exited non-zero on ‘SIP/8007-000000ad’ in macro ‘dial-one’
== Spawn extension (macro-exten-vm, s, 16) exited non-zero on ‘SIP/8007-000000ad’ in macro ‘exten-vm’
== Spawn extension (ext-local, 8040, 2) exited non-zero on ‘SIP/8007-000000ad’
== MixMonitor close filestream (mixed)
== End MixMonitor Recording SIP/8007-000000ad

RTP Timout is controlled under Settings, Asterisk SIP Settings, Chan_SIP settings and defaults to 30s. Sounds like you need it increased.

I thought about that but I dont exactly want to do it system wide, is there a way to do it just for that extension?
BTW, I dont think that would be the perfect solution, audio is being transmitted, modifing RTP timeout would really just be a workaround for the root cause right?