FreePBX | Register | Issues | Wiki | Portal | Support

Transfer to Voicemail not a valid extension


(Sentinel) #1

I am trying to setup transfer to voicemail. I type in ##* using DTMF then the extension and I get “I am sorry that is not a valid extension”. Then it says enter a valid extension which I do at 110. Then the logs show:

This extension does not exist or no password is set

I am dialing for example: ##*110#

The logs show “Invalid extension 0 entered”

Is this a bug? I don’t see any feature codes causing the issue. Fresh install as well


#2

Does your device have a transfer button or softkey? If so, does pressing it, dialing *110 and completing the transfer (device dependent) work correctly?


(Sentinel) #3

I am hitting send. It does have a transfer key as well. I am using Yealink phones


#4

What happens when you press Tran *110 Tran?


(Sentinel) #5

[2018-11-08 23:04:19] VERBOSE[25241][C-00001ecd] pbx.c: Executing [s-NOUSER@macro-user-logon:1] NoOp(“SIP/trunk_incoming-00001e8e”, “Invalid extension 0 entered”) in new stack

I didn’t enter 0. I entered ##*110, then transfer. Same error

Update: ## works. It’s when I hit ##* (Asterisk key), it says I"m sorry that is not a valid extension. If I dial ## then the extension it works as a transfer. When I do ##* it cuts me off at ##

Call trace:
https://pastebin.com/Rw95WMRt


#6

Sorry, I can’t make sense of your log. It does not contain anything with timestamp 23:04:19.

But why are you using ## in the first place? In a situation where normal out-of-band transfer is available (which I believe is true for your case, based on what you have posted so far), just use the TRAN button.

Disadvantages of using ## include:

  1. The first keypress will make a loud beep in the remote party’s ear.
  2. It would prevent you from dialing ## (or any other in-call DTMF command) when connected to a remote IVR.
  3. It can be unreliable if e.g. packet loss prevents the DTMF from being properly recognized.
  4. Unless carefully deployed to ensure that an incoming caller cannot access it, it’s a security vulnerability.

(Tom Ray) #7

Is On-Demand Recording enable for 102?


(Sentinel) #8

I want to do blind transfer to VM. This has worked for years


(Tom Ray) #9

OK, it doesn’t matter if you have a Blind Transfer button on your phone or use ##. My question is still valid. Because a transfer (blind or attended) will put the other channel on hold then dial (in your case) what comes after ## for the new channel. You are dialing *110 (even though the call trace shows 101) but your log is saying “0” doesn’t exist. Do you have a feature code set at *11?

People, including myself, have run into this with the Direct Voicemail transfer because it’s just “*” but you have to make sure that when you dial *100 or *212 you aren’t triggering features codes. *10 is speed dial so they could look for entry 0 by mistake. *21 is the FollowMe toggle so it will attempt to toggle FollowMe for 2. In all those cases you wouldn’t be able to dial direct to voicemail.

I change it to *5 because a lot of systems (like Broadsoft, etc) use that code for the function. Many of my users are coming from other providers using systems like that so it was just an easier choice, training wise.

So no feature codes conflicting?


(Sentinel) #10

There is no *11


(Necits2015) #11

How about a *1 In-Call Asterisk Toggle Call Recording? Also you may have to enable Expose All Feature Codes under Advanced Settings.


(Sentinel) #12

OMG. That was it. Weird thing is, this had to change in an update. I never touch feature codes. The *11 was the issue. It wasn’t shown until I told it to expose. Perhaps sangoma should change these. Every system I have worked on in the last 15 years has the 100-199 extensions.


(Sentinel) #13

This works now if they dial but if they use a BLF key the phone rings. We want to transfer to voicemail using the BLF key. Is that something we can do?


(Necits2015) #14

It depend on the phone your using. With Yealink I set a key with type prefix and a value of * and name it VM-Xfer. Its an additional step but the user presses the transfer button, then the VM-Xfer button and then the BLF.


(Sentinel) #15

when I do that it just rings. Using the BLF would be ## ext not ## extension


(Necits2015) #16

I’m not sure what you mean? My BLF keys are type BLF. What you want is ##* then BLF. Last I checked you couldn’t prefix ##* so I did what I mentioned above. What happens if you Hit Transfer then press * then BLF? It’s been awhile so I may have tweaked a few settings in the Yealink config.


(Sentinel) #17

If I hit *, then the BLF key it just rings the extension. I have a DTMF key setup to dial ## * which works if you dial the extension manually


(Necits2015) #18

I don’t think that (DTMF ##* + BLF) will work. I’ve been over this on the Yealink forums. Can you enter ##* then BLF manually? I’ll look at my config when I get some free time.


(Sentinel) #19

same result when dialing manually. ##* then BLF rings the phone. These are yealink as well


(Tom Ray) #20

Are you in Device/User mode? Because this (I didn’t catch earlier) is an attempt to log in as a user on a device. That is only possible in Device/User mode.

Also is Device/User mode *11 is how you would attempt to log into a device as a user. So basically by dialing ##*110 you are putting the other call on hold and then the PBX is trying to log you in as user 0.

So to recap *11 is how you log in and *12 is how you log out of devices in Device/User mode. These do not exist in Extensions mode (the default mode).