Totally confused - Zulu in 2020


(Volkswagner) #1

Greetings,

I’m running FreePBX distro 14.0.13.34, Asterisk Asterisk 13.32.0, Zulu 14.0.58.3, WebRTC Phone 14.0.3.8

It seems Zulu Desktop client for Mac version v3.2.3+20 does not include the ability to originate voice calls. I can only make it ring a desk phone. This seems odd for a mobility or SoftPhone app. Can anyone explain the reasoning developers would exclude this function.

I’m currently having trouble with WebRTC. I have it enabled for my user (which also has Zulu license).
When logged into the https://fqdn/ucp the phone icon is red and functions are “grayed out”.

I’m using LetsEncrypt for certs and they properly show in my browser. I’ve tried using Google Chrome version 83.0.4103.116 (Safari shows incompatible browser error, but Chrome says the normal “Note: An Active call will not be dropped when this window is closed” message.

Most of the topics and wiki info seem stale. The WebRTC wiki article was last updated October 2017.

My burning question: What do system admins offer to road warriors in 2020? It seems Zulu Desktop is not a solution but a partial package for internal communications. The mobile version of Zulu is not ready for prime time on Apple devices (Android works a bit better but still not stable/reliable for everyday use).

What other info would be helpful to identify why WebRTC fucntions are grayed out?

[root@pbx ~]# asterisk -x "pjsip show transports"

Transport:  <TransportId........>  <Type>  <cos>  <tos>  <BindAddress....................>
==========================================================================================

Transport:  0.0.0.0-udp               udp      3     96  0.0.0.0:5060
Transport:  0.0.0.0-ws                 ws      3     96  0.0.0.0:5060
Transport:  0.0.0.0-wss               wss      3     96  0.0.0.0:5060

I’ve tried various urls and ports all with same result (softphone functions are “grayed out”)
ex: https://fqdn:4443, https://fqdn/ucp, http://fqdn:81


(Volkswagner) #2

I just installed Zulu Client: v3.5.2+215 on my mac.

I see there is a new setting “default Call Device”, but there is only one choice = “Desktop phone”.

Does anyone know if the Beta or Alpha track has the ability to originate a call via softphone?


(Sergio Lobera) #3

Are you enabling Zulu to an specific user or a group ? (talking about User Management)

If you are giving permissions to a user, go to that user, Zulu tab, disable Zulu for that user, Apply, run a fwconsole pm2 --restart zulu (from the CLI), and then re-enable permissions for that user.

If you are giving it to the whole group, same but editing the group.


(Volkswagner) #4

Thank you @slobera
That worked a treat. Not only did that fix the Web SoftPhone in UCP but also
added the second choice in Zulu Desktop to use softphone as default device!

Cheers!


(Volkswagner) #5

It’s also worth noting that the certificate in use must be set as default or the same symptom may occur.


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.