TLS error (everything else working)


I have a fresh installation of FreePBX with the official distro. I have all working fine, but TLS.

I have enabled TLS on SIP configuration, and also in the extension, who says i can connect for 5160 for UDP and 5161 for TLS.

If i connect trough UDP, the soft connects (zoipper, 3cx…) and the asterisk log is normal:

[2018-06-21 10:14:30] VERBOSE[9761] chan_sip.c: Registered SIP '4' at X.X.X.X:50482
[2018-06-21 10:14:30] NOTICE[9761] chan_sip.c: Peer '4' is now Reachable. (167ms / 2000ms)

But if i connect trought TLS, the soft doesn’t connect and the asterisk log says:

[2018-06-21 10:13:35] ERROR[11876] tcptls.c: Problem setting up ssl connection: error:00000001:lib(0):func(0):reason(1), Internal SSL error
[2018-06-21 10:13:35] WARNING[11876] tcptls.c: FILE * open failed!

I have tried with Let’s Encrypts SSL (working on the domain) and self-signed, but both of them shows the same error.

Any cloues?

King regards and thank you!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.