Hey guys I’ve been working on implementing TLS and SRTP in order to allow us to use softphones on our cell phones in order to make calls while preventing the password from being stored in text and am unable to get SRTP to work. Any time that I enable it I receive an error saying 403 forbidden. However changing the transport setting to TLS only works just fine. I’ve been following this article and still have trouble. Do I even need to worry about SRTP if TLS is working and if so any ideas how to get it to work? Thanks.

Earlier verions of FreePBX were using port 5060 for pjsip and 5061 for chansip. It was recently changed to conform to and RFC standard where port 5060 is used for chansip, 5061 for chansip over TLS, and 5062 for pjsip. Make sure these settings are correct and that you open porn 5061 on your router’s firewall for TCP only traffic. I am also using softphones on about five cells phones (zoiper), a polycomm VVX300, and a Grandstream HT502 on FreePBX 13 successfuling using TLSv1 and SRTP.