Tls and srtp not configured with grandstream and commercial EPM

Hi, I am trying to configure sip tls and srtp on with my grandstream phones. I am using current FreePBX 13 and commercial EPM. i have the extensions set up for tls and srtp, but the configs that EPM generates for the phones do not contain any of the encryption configs… the port is still 5060 and tls is not enabled.

how do i get EPM to generate a proper config for this?


Make the EPM connect to random ports rather than using 5060 for the TLS. 5060 is only for the call setup and auth, not the actual data streams. Had this same issue setting up grandstream wave with video. Works beautifully over LTE plus I get very good video.

Endpoint manager doesn’t respect transports. It will not generate the proper TLS config for your device. Use the basefile editor to set the necessary parameters for your template, and go about it that way.