TLS - Aastra Phone


Trying to get an aastra 6867i phone using TLS to register with FreePBX.

Asterisk 13.22.0
Chan sip
Godaddy cert uploaded using the FreePBX Certificate Management

I getting the following error on the asterisk CLI.

[2019-06-28 13:29:48] ERROR[4638]: tcptls.c:727 handle_tcptls_connection: Problem setting up ssl connection: error:00000001:lib(0):func(0):reason(1), Internal SSL error
[2019-06-28 13:29:48] WARNING[4638]: tcptls.c:814 handle_tcptls_connection: FILE * open failed!

I ran the command “fwconsole chown” to make sure it was not a file permission issue.

Anyone have an idea what is causing this error?

Where is the file in your system?, does asterisk have access to it?

Wish the log could be specific on what file it could not open. Tried turning on asterisk debugging in the CLI which did not provide any additional info.


-rw------- 1 asterisk asterisk 1674 Jun 28 09:53 comtel.key
-rw------- 1 asterisk asterisk 8697 Jun 28 09:53 comtel.pem

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.