TIPS needed: PJSIP endpoints (5060) vs chan_SIP (5160) (solved)


Can someone remind me of what I missed?

NEW install (fresh): SangomaOS from .ISO

2 extensions created
101 = PJSIP (using) port 5060 (default from install)
102 = chan_SIP (using) port 5160 (default from install)

Both endpoints are registered (OK)
Both endpoints are remote from the PBX (sitting) on a NAT-LAN
Both endpoints are on the same remote LAN

Here is the concern:
101 (PJSIP)
When you dial *65#
You do NOT HEAR the audio from the announce extension feature key
outbound calls: Have NO audio

102 (chan_SIP)
When you dial *65#
You DO HEAR the audio from the announce extension feature key
outbound calls: Have good 2-way audio

What did we miss when building the default port 5060 PJSIP extensions.

Remember: this is a brand new (activated) fresh install of SangomaOS using .ISO

I added 2 endpoints, a trunk, and SET the external IP address.
I did a few other very minor other things (like a ring group) and added MOH .WAV file.

I thought maybe since we have a PJSIP remote extension sitting behind a LAN-NAT: we might need to setup something for NAT, but there is no choices for this in the UI.

NOTE: 102 (chan_SIP) has its NAT mode set to: YES
There is NO NAT settings for PJSIP extensions.

Thanks for any tips!

tip one - disable chan_sip , use a single channel driver , pjsip , on port 5060

trouble shoot from that angle , there are options to adjust nat behavior with PJsip extensions advanced tab - generally the defaults are fine

finally use sngrep from the command line for real time insight or sysadmins packet capture for Wireshark analysis

start locally and confirm operation with no nat initially if possible then move device remote

why not use both channel drivers?
They are installed and working by default using (2) different ports?
5060 vs 5160

In fact, if not for the chan_SIP 5160 process: I would not have known the PJSIP process has no audio (good 'ol chan_SIP to the rescue).

Why shut down chan_SIP UDP on 5160 when it really has nothing to do with PJSIP UDP on port 5060?

Just asking for why the disable is needed when by default SangomaOS runs them both …

chan_SIP fan here (it just works) and is rather easy to troubleshoot.

I’m glad SangomaOS now includes: sngrep
I recall the days before this was the case.

I’ll look over your other tips.

working now.

PJSIP on port 5060 for a remote NAT-LAN IP phone
chan_SIP on port 5160 for a remote NAT-LAN IP phone

both have audio when dialing the feature keys.
both have 2-way audio for outbound calls.

I reloaded asterisk at the CLI with:

core stop now
asterisk -r

Chan_sip is deprecated, hence the advice against using it. If you had installed 16, you would have found a single driver only. Only use fwconsole to start asterisk.

Problem is that using UDP signalling on port 5060 or 5160 for SIP are the most unnecessary and rash mistakes you have made (watch sngrep to see why :wink: )

Thank you for the follow up, dicko!

Been a while since I’ve heard from you.
Glad to be back on the forum!

Got it, Lorne.
Thanks for this follow up.

Yes. My .ISO is from the past, but not too far back.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.