Tip: session-timers=refuse, needed after upgrade to

asterisknow 1.5

INFO ONLY. NO freePBX dev. attention needed.

Just sharing in case this saves other freePBX users a lot of time. We just did an IN-PLACE asterisk upgrade to form, with freePBX

The one major issue (so far) was the sudden occurrence of NO AUDIO, IN EITHER DIRECTION, on only INBOUND calls, where a previously perfectly operating pbx had been. The audio was problem free for OUTBOUND calls. The work-around,


It can be added through the GUI > Asterisk SIP Settings > Other SIP settings.

Presto bi-directional audio restored.

Bug in asterisk-core sip is being worked (https://issues.asterisk.org/view.php?id=15621)


is this a bug that Asterisk is working or is it something that you believe we need to add to FreePBX when running on 1.6?

If you consider it something that we need to do, please file a bug for it. If it is something that should be resolved in Asterisk, then we should leave it be.

It’s an asterisk bug. No freePBX developer action needed. I posted in the “tip/tricks” section intended as INFO-ONLY for the freePBX community who may also stub their toe on this.

The new v2.6.0.0 SIP settings page compels some NAT settings which, if incorrectly set, can provoke one- and two-way audio problems; however, in the asterisk context, a freePBX user may waste a lot of time looking in the wrong spot. So I posted a “tip” here.

I’ll edit the orig. post to highlight a INFO-ONLY tip.

Sorry to confuse.

the tip is appreciated. And it wouldn’t be the first time that we have worked around Asterisk issues in FreePBX if they were expected to be long lived issues so I always like to check.

Thanks for posting.