TIP: How to fix: Server time (GUI) module:Time Groups

Hi SangomaOS Team:

FreePBX 13.0.197

Yes this is an older version of FreePBX.

Could you help with a tip to fix an incorrect server time (for) Time Groups and Time Conditions (UI) modules?

The time is OFF by 1 hour (behind).

What is interesting is:
If using SSH and the date command:
time is correct
also
If using an endpoint and dialing the feature code *60:
time is announced correctly

The timezone is set correctly in: system admin (module)
The PHP.ini file is correct: /etc/php.ini

For some reason, only the GUI time for Time Groups and Time Conditions is off by 1 hour (behind)

Maybe: something to do with daylight savings, but not sure what the fix is.

Thanks for any tips.

https://wiki.freepbx.org/display/DIMG/Time+Zone+Setting+-+UTC+Offset

I do not think it is an issue in newer versions, but at one point you had to manually adjust.

I think the fix will be:

yum update tzdata

I’m not sure now that the CentOS 6.x repos are “gone”.
I’ll find out soon.

1 Like