Timezone Problem

Hello to all.
I have read numerous posts about timezone configuration but nothing seems to work in mine case.

First off all at the first connection in the gui where the initial setup is made I used my preferred time zone (Europe/Athens UTC +3).

When I set the system admin - Timezone option to UTC/UTC I’m getting :

[[email protected] ~]# timedatectl
Local time: Wed 2019-04-24 09:10:20 UTC
Universal time: Wed 2019-04-24 09:10:20 UTC
RTC time: Wed 2019-04-24 09:10:20
Time zone: UTC (UTC, +0000)
NTP enabled: yes
NTP synchronized: no
RTC in local TZ: yes
DST active: n/a

When I enable at the system admin - Timezone : Europe/Athens before the reboot at the blue text box besides the dropdown fields I get the right time but when I reboot the machine I get:

[[email protected] ~]# timedatectl
Local time: Wed 2019-04-24 09:24:30 EEST
Universal time: Wed 2019-04-24 06:24:30 UTC
RTC time: Wed 2019-04-24 09:24:31
Time zone: Europe/Athens (EEST, +0300)
NTP enabled: yes
NTP synchronized: no
RTC in local TZ: yes
DST active: yes
Last DST change: DST began at
Sun 2019-03-31 02:59:59 EET
Sun 2019-03-31 04:00:00 EEST
Next DST change: DST ends (the clock jumps one hour backwards) at
Sun 2019-10-27 03:59:59 EEST
Sun 2019-10-27 03:00:00 EET

So from what I understand is that it keeps the local time always the same and changes the utc time (in my case -3 hours).

I want to achieve the exact opposite.
I need to keep the utc time same and the local time +3 hours (Athens /Europe).

Another thing that troubles me is that the ntp sychronized is set to no.

Any help will be much appreciated.

The workaround that I used is that I set up the hardware clock (via bios) to Athens/Europe time and reverted the system admin-> timezone to UTC.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.