TimeZone not working correctly

I have tried everything I know to get asterisk/freepbx to give me Asia/Hong_Kong zone to no avail.

The only place I was able to actually find a current time within asterisk/freepbx was inside the Add Time Group where it gives a live Server time. My server time is correct with Asia/Hong_Kong time. But asterisk/freepbx when I call *60 is giving me London, UK time.

I did tell asterisk on install to use HK time and from what I see it says it is, but obviously something somewhere is amiss.

I did NOT install DADHI or Zaptel although Zaptel Channel DIDs appears in the menu.

Would greatly appreciate any advice on HOW to make asterisk/freepbx actually USE Asia/Hong_Time zone. Even better a way to sync asterisk with some external world clock for that time zone.

Asterisk/Freepbx is running on Amazonaws EC2 Nothern California

RHEL6
Asterisk 1.8.7.1
FreePBX 2.9.0.7

Every module in Basic, Extended and Unsupported is installed and up to date. Many have simply been disabled.

Basic
Core 2.9.0.2 FreePBX Enabled
Fax Configuration 2.9.0.5 Schmoozecom.com Disabled
Feature Code Admin 2.9.0.0 FreePBX Enabled
FreePBX ARI Framework 2.9.0.6 FreePBX Enabled
FreePBX FOP Framework 2.9.0.1 FreePBX Enabled
FreePBX Framework 2.9.0.7 FreePBX Enabled
FreePBX Localization Updates 2.9.0.1 FreePBX Enabled
SIPSTATION 2.9.0.1 Bandwidth.com Disabled
System Dashboard 2.9.0.4 FreePBX Enabled
Voicemail 2.9.0.5 FreePBX Enabled

Advanced Administration
Asterisk SIP Settings 2.9.0.5 Bandwidth.comEnabled
Bulk DIDs 2.9.0.2 Enabled
Bulk Extensions 2.9.0.5 Enabled
Custom Applications 2.9.0.1 FreePBX Enabled

CID & Number Management
Phonebook Directory 2.9.0.2 FreePBX Disabled
Speed Dial Functions 2.9.0.1 FreePBX Disabled

End Point Manager
PBX End Point Manager 2.9.2.9 Andrew Nagy Enabled

Inbound Call Control
Announcements 2.9.0.2 FreePBX Enabled
Blacklist 2.9.0.1 FreePBX Enabled
Call Flow Control 2.9.0.3 FreePBX Enabled
CallerID Lookup 2.9.0.5 FreePBX Disabled
Directory 2.9.0.12Schmoozecom.com Enabled
Follow Me 2.9.0.6 FreePBX Enabled
IVR 2.9.0.5 FreePBX Enabled
Queue Priorities 2.9.0.1 FreePBX Disabled
Queues 2.9.0.12 FreePBX Disabled
Ring Groups 2.9.0.6 FreePBX Enabled
Time Conditions 2.9.0.7 FreePBX Enabled

Internal Options & Configuration
Bulk Phone Restart 2.9.0.2 Schmoozecom.com Enabled
Call Forward 2.9.0.1 FreePBX Enabled
Call Waiting 2.9.0.0 FreePBX Enabled
Callback 2.9.0.4 FreePBX Enabled
Camp-On 2.9.0.0 FreePBX Disabled
Conferences 2.9.0.2 FreePBX Disabled
DISA2.9.0.4 FreePBX Disabled
Dictation2.9.0.0FreePBXEnabled
Do-Not-Disturb (DND) 2.9.0.1 FreePBX Disabled
Info Services 2.9.0.0FreePBX Enabled
Languages 2.9.0.3 FreePBX Disabled
Misc Applications 2.9.0.2 FreePBX Enabled
Misc Destinations 2.9.0.1 FreePBX Enabled
Music on Hold 2.9.0.1 FreePBX Enabled
PIN Sets 2.9.0.1 FreePBX Enabled
Paging and Intercom 2.9.0.5 FreePBX Disabled
Parking Lot 2.9.0.4 FreePBX Disabled
Recordings 3.3.11.2 FreePBX Enabled
Voicemail Blasting 2.9.0.3 FreePBX Disabled

Support
Asterisk Logfiles 2.9.0.1 FreePBX Enabled
Online Support 2.9.0.1 FreePBX Disabled

System Administration
Asterisk API 2.9.0.3 FreePBX Enabled
Asterisk CLI 2.9.0.2 FreePBX Enabled
Asterisk Info 2.9.0.3 FreePBX Enabled
Backup & Restore 2.9.0.3 FreePBX Enabled
Java SSH 2.9.0.0 FreePBX Disabled
PHP Info 2.9.0.1 FreePBX Enabled
Phonebook 2.9.0.3 FreePBX Enabled
Print Extensions 2.9.0.1 Bandwidth.com Disabled
Route Congestion Messages2.9.0.1 Bandwidth.com Disabled
Weak Password Detection 2.9.0.1 Schmoozecom.com Enabled

Third Party Addon
Google Voice0.6.0 Marcus Brown Enabled

What does Tools > System Admin > Time Zone show?

Start up the Asterisk console. Dial *60 and capture the output. Look for the following line

-- Executing [*[email protected]:9] SayUnixTime("SIP/6080-00000074", "1321448934,,kM 'and' S 'seconds'") in new stack

Here is a link that explains SayUnixTime

http://www.voip-info.org/wiki/view/Asterisk+cmd+SayUnixTime

From a unix command shell run the date command and post the output.

What does Tools > System Admin > Time Zone show?

I do not have a Tools > System Admin I do have TOOLS > Advanced Settings and there is nothing listed in there for Time Zone. But, in Setup > General Settings it says:

International Settings

Country Indications: Hong Kong
24-hour format: yes

As for question 2: I get the same result as above

-- Executing [*[email protected]:9] SayUnixTime("SIP/800-00000007", "1321485368,,kM 'and' S 'seconds'") in new stack

The funny thing is Freepbx Add Time Group gives me the Hong Kong Timezone.

So here is what I ran:

ls -al /etc/localtime
lrwxrwxrwx. 1 root root 34 Nov 13 03:41 /etc/localtime -> /usr/share/zoneinfo/Asia/Hong_kong

/usr/sbin/zdump /etc/localtime
/etc/localtime Thu Nov 17 00:44:10 2011 UTC

date: gave me wring timezone so I edited
/etc/sysconfig/clock

date
Thu Nov 17 08:45:23 HKT 2011

rebooted the server hoping asterisk would self adjust but no luck.

Even though my system time was not set to HK freepbx was showing that to be the timezone, yet asterisk showed server time, now asterisk is still showing the old timezone even after the reboot.

Asterisk was installed with the HK timezone, so is there a specific file in asterisk/freepbx I can manually edit to force it to change? Rebooting system now is not a problem since I cannot deploy the system for use until it shows the correct time!

Turns out this was my typo mistake, I had called Hong_Kong Hong_kong

Nothing like chasing your own tail for 2 days!