Timeout on outgoing iax trunk

  1. My PSTN provider does not support signalling of recipient pickup.
  2. FreePBX has a 300 second timeout on outgoing calls.
  3. The combination of 1 & 2 means if you make a call to for instance a help desk that lasts longer than 300 seconds the call is cut off with the message that the call has not been picked up. This is a major problem.

Can sombody please tell me how to fix the configuration to eliminate the timeout or make it much longer so it is no longer a problem.

It turns out the timeout is hard coded in the conf files.

I am new to dial plans so I am asking if there is a way I can override the default in one of the custom conf files

Please let me understand this. You have an IAX trunk to your provider. This a digital facility. They are completing all calls as “early media”? This is completely f****ed up. That means you don’t have any CDR’s nor do the timers work.

I think extending the dial time is the least of your issues.

It would take some digging but I think the dial string is assembled downstream of dialparties.agi. That file is not written on reload so you can hack it up. You will have to rehack with every update. With any luck it is declared as a global. Follow the login in dialparties.agi.

Let me understand also . . .

My PSTN provider does not support signalling of recipient pickup.

I would have to say WTF?? PSTN means Public Service Telephone Network, are they that (land lines) or are you confused between VSP’s and PSTN? If you have a PSTN provider that doesn’t know when you make a call. then make lots of them they will not be able to charge you :slight_smile:

I think he means answer.

To that I go back and say that the timer on phones does not work, I bet parking does not work, can you transfer a call in early media? No CDR’s

I have simply never heard of anything like this.

I think it is the last set of digits passed in the dial string. Looks like it comes from macro-dialout-trunk

Executing [[email protected]:20] Dial("SIP/Pioneer-SIP-b1f4b098", "SIP/Flowroute/xxxxxxxxx|300|") in new stack

The only problem is the call pickup. I get caller ID no problem on the incoming. I have been using them for years and they provide good service including that I can fax over the trunk. For calls less than 5 min it is working very well with voice quality much better than most providers. Everything was working fine until I upgraded to FreePBX from AsterisxNow.

I have been able to determine that the timeout has been hard coded into the dialplan in the fpbx generated files. If I could change the timeout to 1 hr instead of 5 min then it would solve the problem.

I am not familiar with the details of how dialplans work but I have tried hacking the extensions-custom.conf without success maybe because of some minor detail.

Paid support told me and I quote “We’ve never heard of any such setting” until I rubbed their noses in it.

Whatever, the alphabet soup is not really important. They are the provider who connects my calls to the PSTN. I get “ringing”, “busy”, “hungup” etc. but they don’t do “pickedup”. FPBX hard codes a 5 min timeout that waits for pickedup then kills the call right in the middle of a conversation

I neither have any idea what “pickedup” means sorry.

I agree about the lack of function when in early media, perhaps a custom trunk with a custom dialstring
IAX2/hiscarrier/$OUTNUM$|3000|

(Happy BDay)

That would work, great job!

Thanks from the old man