Timecondition not working when i want FreePBX to ignore the call


Maybe the answer to my problem is simple but i `m out of ideas.

I`m running Freepbx(version:, asterisk version 13.19.0) on my Raspberry 3.
I have need only for inboud routes and those numbers(9 in total) are working fine.

However, one number needs to be configured so that at certain time, calls come to my Raspberry and it will answer it and other times my server simply ignores the call and the phone is ringing in different location(that is not in my server) on a regular household.

I have set up Time Groups and Time Conditions.
On TG i have start and finish times set up.
On TC i have default settings, except:
Time Group is matched to my previously set up Time Group
Destination Matches -> Announcement -> myannouncement
Destination non-matches -> Terminate call -> Hangup

When going to Connectivity -> Inbound Routes:
I have set up a new route for that one specific number, all are defaults but
Set destination -> TimeConditions -> My previously set up Time Condition.

When i call the number, my server always answers it. No matter what the time is, it does not go to other location i want.
If i disable trunk, then it ofcource rings in other location.

Basically, if there is a way i could enable / disable the trunk by setting a timecondition, it would work just fine.

Does someone have an idea how can i make this work or point me to right direction?
Maybe something to change in Destination non-matces field?


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.