Time differs between freepbx 14 and centos

I noticed this problem because I am trying to set a cron job to shut down an restart the server but it’s not working at correct time for some reason, this turned out to be differing times as stated above.
I have Europe/London in settings, the server time in sysadmin is different by 1 hour than that given with date command in cli, I have had to move the cron shutdown time. not sure if this is a bug or I’m doing something wrong.

@alexcal If you haven’t resolved this, please reboot the server and let me know if things are resolved.

Hi cullenl,

I tried that before posting here but I have rebooted today and here are results:

It doesn’t appear you’ve selected a time zone; can you do that and retest?

Also note the server is showing time in UTC and the ui is in EST. That said the minutes in your screenshot are 7 minutes apart. No time issue will separate 7 minutes on the same server

1 Like


sudo yum install ntp

Once installed, you can ensure the service will run at boot time by running:

sudo /sbin/chkconfig ntpd on

Hi, thanks for replies.

@cullenl When you select correct time zone and submit the fields show blank.

@jfinstrom That’s the time difference between taking screen shot - purely slowness on my part.

@fender_bender5150 I ran the install ntp and althought it stated nothing to do, the time of both was the same so it looks like it worked - many thanks.

If you run the command Cullen suggested and the database shows a timezones but the drop-downs are empty that is a bug. You can file at issues.freepbx.org.