Time Conditions bug? Coming on an hour later

after recent updates, time conditions are set to 8:30 and time on the PBX is correct but it’s kicking on at 9:30. Just started doing this.

Exactly 1 hour sounds like a timezones setting

U sure there is no timezone specified on the time condition?

yes that’s on

Is it a virtual machine?

yes but all other VMs are fine

I had the same problem on one freePBX machine a few months ago. I think I had to switch to a different time zone in the Linux OS, which wasn’t mine…but worked. Cannot remember, if this was the final solution or only a temporary fix. I will check…

Time zone changes require a reboot.

TimeZone is correct but odd. It shows the wrong timezone selected but the system time shows correct

Lots of clocks and timezones in linux, there is a hardware clock and system timezone

cat /etc/sysconfig/clock

There are also a web php timezone and a CLI timezone. (defined in the various php.ini’s )

locate php.ini

Do you get the correct time when you run


I had the same issue when installing FreePBX onto a Raspberry PI. The reason that this happens is the system time on the computer running the PBX does not have to correct time. Change the system time to automatic - you can normally find code online of how to update the time settings. After you do this, you will see that the time conditions are working correctly.

set back to New York again and rebooted PBX to correct issue

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.