This deployment is already licensed to a different host. It needs to be unlinked through the portal


(John Hilb) #1

Hello, a while back we upgraded from FreePBX 13 to 14 and in the process had to build a new PBX and migrate our data (Hyper-V). I noticed the other day that we hadn’t moved our deployment ID over for our commercial modules (in this instance just Sysadmin Pro). Our old deployment was out of automated deactivations so I put in a support ticket to have the ID freed up so I could associate it with our SNG7 install.

Support replied that they freed up the deployment ID and I should be good to go, however now when I try to activate FreePBX, I’m receiving the error “This deployment is already licensed to a different host. It needs to be unlinked through the portal.” This happens both through the WebGUI and CLI.

I contacted support again and they told me it was indeed freed up and if I needed any more help I needed to make a technical support ticket. Well, to do that I’d have to pay for support credits which cost WAY more than the license I’m trying to recover. I’m unable to use the free commercial module support as this module was purchased more than 1 year ago. I also asked if they can just transfer the commercial license to a new deployment ID and they told me they cannot.

Do I have any recourse? The license itself is only $25 which isn’t a big deal, but if we’re just SOL that definitely means we won’t be purchasing any more commercial module licenses from Sangoma if we can help it… it leaves a real sour taste to just “lose” a license due to back end activation issues.

Thanks for your help!