The following modules are disabled because they are broken: UpdateNeeded

I recently inherited an Asterisk installation running Debian Sarge. The current admin had attempted to upgrade FreePBX from 2.1.1 to 2.5.1, and the upgrade failed. The main web page and retrieve_conf fail due to a MySQL syntax error. Sarge provides MySQL 4.0, and this seems to be the cause. I recall there were some significant syntax changes in MySQL from 4.0 to 4.1. I upgraded Debian to Edge and picked up MySQL 5.0. After that, everything seemed fine except for the following error on the System Status page :

You have a broken module
The following modules are disabled because they are broken:
UpdateNeeded

You should go to the module admin page to fix these.
Added 0 minutes ago
(freepbx.modules_broken)

There is a module listed in the Module admin called UpgradeNeeded, but it’s bogus. I reran the upgrade again (yes, with --force-version=2.1.1) and still no luck. This doesn’t appear to be causing any problems, but I need to make this go away. Where is this rouge module name being stored and how do I clear it out?

Chris

If you list all modules with /var/lib/asterisk/bin/module_admin list what is the module name listed as broken?

Module Version Status


UpdateNeeded 1 Broken
backup 2.5.1.5 Enabled
builtin Enabled
callback 2.5.0.2 Enabled
callforward 2.5.0.1 Enabled
callwaiting 2.5.0 Enabled
conferences 2.5.1.6 Enabled
core 2.5.1.3 Enabled
customappsreg 2.5.0.4 Enabled
dashboard 2.5.0.5 Enabled
disa 2.5.1.6 Enabled
donotdisturb 2.5.0.5 Enabled
featurecodeadmin 2.5.0.3 Enabled
findmefollow 2.5.1.7 Enabled
framework 2.5.1.0 Enabled
infoservices 2.5.0.1 Enabled
ivr 2.5.20.5 Enabled
miscdests 2.5.0.2 Enabled
music 2.5.1.2 Enabled
paging 2.5.0.6 Enabled
pinsets 2.5.0.1 Enabled
queues 2.5.4.5 Enabled
recordings 3.3.8.8 Enabled
ringgroups 2.5.1.6 Enabled
timeconditions 2.5.0.8 Enabled
voicemail 2.5.1.5 Enabled

Try /var/lib/asterisk/bin/module_admin delete UpdateNeeded and see if that cures it

The script complained (see below), however it appears to have fixed the problem. So did this just clear cruft out of the database, and it’s just complaining that there was no actual module present?

Thanks mickecarlsson! :wink:

pbx:/var/www/admin# /var/lib/asterisk/bin/module_admin delete UpdateNeeded

The following error(s) occured:

  • Failed to run un-installation scripts
    pbx:/var/www/admin# /var/lib/asterisk/bin/module_admin list

It cleared the database and removed any leftovers tied to the UpdateNeeded module (which was not a module).

I am glad that the problem was solved. Thank you for the feedback.