That is not a valid conference number

Hi All

Small hitch setting up a conference - whatever I do, the user always gets the message “that is not a valid conference number”, after entering the PIN

If I enter the wrong PIN, it tells me, so it is clearly associating the call with the correct conference

Below is what appears on the cli:-

-- Executing Set("SIP/3001-08b2e480", "MEETME_ROOMNUM=5") in new stack
-- Executing GotoIf("SIP/3001-08b2e480", "0?READPIN") in new stack
-- Executing Answer("SIP/3001-08b2e480", "") in new stack
-- Executing Wait("SIP/3001-08b2e480", "1") in new stack
-- Executing Read("SIP/3001-08b2e480", "PIN|enter-conf-pin-number||") in new stack
-- Playing 'enter-conf-pin-number' (language 'en')
-- User entered '5'
-- Executing GotoIf("SIP/3001-08b2e480", "1?USER") in new stack
-- Goto (from-internal,5,9)
-- Executing Set("SIP/3001-08b2e480", "MEETME_OPTS=ciMs") in new stack
-- Executing Goto("SIP/3001-08b2e480", "STARTMEETME|1") in new stack
-- Goto (from-internal,STARTMEETME,1)
-- Executing MeetMe("SIP/3001-08b2e480", "5|ciMs|5") in new stack

== Parsing ‘/etc/asterisk/meetme.conf’: Found
== Parsing ‘/etc/asterisk/meetme_additional.conf’: Found
– Playing ‘conf-invalid’ (language ‘en’)

Any ideas?

Cheers

Thanks Rick

A belated update, I ignored the problem for a while

ztdummy was running

Recently I upgraded asterisk and freepbx and behold it suddenly works :slight_smile:

Cheers

Do you have zaptel installed? If you are not using a card of any type you
have to have a USB port on the machine and ztdummy running.

Rick

-----Original Message-----
From: [email protected]
[mailto:[email protected]] On Behalf Of benmack
Sent: Friday, November 24, 2006 11:06 AM
To: [email protected]
Subject: [Amportal-users] That is not a valid conference number

Hi All

Small hitch setting up a conference - whatever I do, the user always gets
the message “that is not a valid conference number”, after entering the PIN

If I enter the wrong PIN, it tells me, so it is clearly associating the call
with the correct conference

Below is what appears on the cli:-

-- Executing Set("SIP/3001-08b2e480", "MEETME_ROOMNUM=5") in new stack
-- Executing GotoIf("SIP/3001-08b2e480", "0?READPIN") in new stack
-- Executing Answer("SIP/3001-08b2e480", "") in new stack
-- Executing Wait("SIP/3001-08b2e480", "1") in new stack
-- Executing Read("SIP/3001-08b2e480", "PIN|enter-conf-pin-number||") in

new stack
– Playing ‘enter-conf-pin-number’ (language ‘en’)
– User entered ‘5’
– Executing GotoIf(“SIP/3001-08b2e480”, “1?USER”) in new stack
– Goto (from-internal,5,9)
– Executing Set(“SIP/3001-08b2e480”, “MEETME_OPTS=ciMs”) in new stack
– Executing Goto(“SIP/3001-08b2e480”, “STARTMEETME|1”) in new stack
– Goto (from-internal,STARTMEETME,1)
– Executing MeetMe(“SIP/3001-08b2e480”, “5|ciMs|5”) in new stack
== Parsing ‘/etc/asterisk/meetme.conf’: Found
== Parsing ‘/etc/asterisk/meetme_additional.conf’: Found
– Playing ‘conf-invalid’ (language ‘en’)

Any ideas?

Cheers


Ben


Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net’s Techsay panel and you’ll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users


Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net’s Techsay panel and you’ll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

Post generated using Mail2Forum (http://www.mail2forum.com)

Hello,

I have exactly the same problem with FreePBX 2.5 and the conference module 2.5.1.5… Whatever I do I can hear “that is not a valid conference number…”

And ztdummy is running !

-- Executing [[email protected]:1] Macro("SIP/5004-09dae0c8", "user-callerid|") i
-- Executing [[email protected]:1] Set("SIP/5004-09dae0c8", "AMPUSER=5004") in
-- Executing [[email protected]:2] GotoIf("SIP/5004-09dae0c8", "0?report") in
-- Executing [[email protected]:3] ExecIf("SIP/5004-09dae0c8", "1|Set|REALCALL
-- Executing [[email protected]:4] Set("SIP/5004-09dae0c8", "AMPUSER=5004") in
-- Executing [[email protected]:5] Set("SIP/5004-09dae0c8", "AMPUSERCIDNAME=GS
-- Executing [[email protected]:6] GotoIf("SIP/5004-09dae0c8", "0?report") in
-- Executing [[email protected]:7] Set("SIP/5004-09dae0c8", "AMPUSERCID=5004")
-- Executing [[email protected]:8] Set("SIP/5004-09dae0c8", "CALLERID(all)="GS
-- Executing [[email protected]:9] Set("SIP/5004-09dae0c8", "REALCALLERIDNUM=5
-- Executing [[email protected]:10] GotoIf("SIP/5004-09dae0c8", "0?continue")
-- Executing [[email protected]:11] Set("SIP/5004-09dae0c8", "__TTL=64") in ne
-- Executing [[email protected]:12] GotoIf("SIP/5004-09dae0c8", "1?continue")
-- Goto (macro-user-callerid,s,19)
-- Executing [[email protected]:19] NoOp("SIP/5004-09dae0c8", "Using CallerID
-- Executing [[email protected]:2] Set("SIP/5004-09dae0c8", "MEETME_ROOMNUM=2050"
-- Executing [[email protected]:3] GotoIf("SIP/5004-09dae0c8", "0?USER") in new s
-- Executing [[email protected]:4] Answer("SIP/5004-09dae0c8", "") in new stack
-- Executing [[email protected]:5] Wait("SIP/5004-09dae0c8", "1") in new stack
-- Executing [[email protected]:6] Set("SIP/5004-09dae0c8", "MEETME_OPTS=") in ne
-- Executing [[email protected]:7] Goto("SIP/5004-09dae0c8", "STARTMEETME|1") in
-- Goto (from-internal,STARTMEETME,1)
-- Executing [[email protected]:1] MeetMe("SIP/5004-09dae0c8", "2050||") i

== Parsing ‘/etc/asterisk/meetme.conf’: Found
== Parsing ‘/etc/asterisk/meetme_additional.conf’: Found
[color=#FF0000] – <SIP/5004-09dae0c8> Playing ‘conf-invalid’ (language ‘en’) [/color]
== Spawn extension (from-internal, STARTMEETME, 1) exited non-zero on 'SIP/500
– Executing [[email protected]:1] Macro(“SIP/5004-09dae0c8”, “hangupcall”) in
– Executing [[email protected]:1] ResetCDR(“SIP/5004-09dae0c8”, “w”) in ne
– Executing [[email protected]:2] NoCDR(“SIP/5004-09dae0c8”, “”) in new st
– Executing [[email protected]:3] GotoIf(“SIP/5004-09dae0c8”, “1?skiprg”)
– Goto (macro-hangupcall,s,6)
– Executing [[email protected]:6] GotoIf(“SIP/5004-09dae0c8”, "1?skipblkvm
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] GotoIf(“SIP/5004-09dae0c8”, “1?theend”)
– Goto (macro-hangupcall,s,11)
– Executing [[email protected]:11] Hangup(“SIP/5004-09dae0c8”, “”) in new
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on 'SIP/5004-09da
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on 'SIP/5004-09da

Thanks!

I just upgraded from *now to FreePBX. Same conference issue.

up?

We just recently upgraded to FreePBX 2.5.1.1 (Conferencing Module 2.5.1.7) on Asterisk 1.4.22. We had an existing conference room (previously worked on FPBX 1.4.x & Ast 1.2.x) that resulted in the same message above. Even deleting and recreating it didn’t help.

Zaptel (ver 1.4.12.1) is installed and running with only the ztdummy module loaded.

What else can I check in an attempt to get this running again?

After reading this and 5 other forum posts on this topic, here’s my fix for my setup.

  1. As I have no telephony hardware installed, make sure ztdummy is loaded:
    ]$ lsmod | grep dummy
    ztdummy 7876 0
    zaptel 194308 1 ztdummy

  2. With the upgrade of my system I think I’m still using zaptel instead of DAHDI, so add the following to [options] section of /etc/asterisk/asterisk.conf:
    dahdichanname = no

  3. Verify and change the following ownership and permissions:
    ]$ sudo ls -ld /dev/zap/
    drwxr-xr-x 2 root root 120 Jan 20 09:39 /dev/zap/
    ]$ sudo ls -l /dev/zap/
    total 0
    crw-rw---- 1 root asterisk 196, 254 Jan 20 09:39 channel
    crw-rw---- 1 root asterisk 196, 0 Jan 20 09:39 ctl
    crw-rw---- 1 root asterisk 196, 255 Jan 20 09:39 pseudo
    crw-rw---- 1 root asterisk 196, 253 Jan 20 09:39 timer

  4. Reload Asterisk
    ]$ sudo asterisk -rx “reload”

Ultimately the root cause of the problem I believe to be the permissions of /dev/zaptel/pseudo, but I’d already made some of the other changes before I got this far. This can be determined by either following the above, or:

]$ sudo grep “app_meetme.c” /var/log/asterisk/full
[Jan 20 09:25:06] WARNING[6183] app_meetme.c: Unable to open pseudo device

Hope this helps.

Is there a fix using DAHDI or how do you install zaptel dummy if you have dahdi dummy already installed?

Thanks