Tgrp= value in sip contact

My SIP Provider says I need to declare my trunk group value tgrp= but i cannot find this declaration as a valid option in Trunk or Registration String.

This is for my other post i have about multiple trunks for the same PBX from the same provider.

Has anyone ever worked with a company who has a Genband C15 before because they are pushing to separate via trunk groups and i’ve been scratching my head.

20 Hours
0 Responses

So what do you all do when you have a PBX and a SIP trunk provider that wants to sell you two trunks because they need to segment LATA’s.

I have a PBX that holds a company that has 3 locations geographically they are across county lines.

To me 1 trunk to rule them all.

Has anyone ever had this come up.

I’ve tried everything with them and yesterday we tried moving to registration strings and all day i get.

[2015-12-16 08:53:57] NOTICE[2078]: chan_sip.c:15170 sip_reg_timeout: – Registration for ‘[email protected]’ timed out, trying again (Attempt #12677)
[2015-12-16 08:53:57] NOTICE[2078]: chan_sip.c:23524 handle_response_register: Failed to authenticate on REGISTER to ‘[email protected]’ (Tries 3)

That makes me think that my provider has a mis configuration and if we just shift all trunks to register strings we can differentiate that way.

I am going to turn up a Panasonic SIP PBX and connect that back because apparently GenBand doesn’t like Asterisk.

In the VOIP world the concept of a LATA is really not important, nor county lines or even country borders. The tgrp is a SIP header thing , I don’t think it is covered by the available SIP stacks in Asterisk. But as background

so you could perhaps play with “cutting up” SIP-HEADER(tgrp) as the [from-pstn-toheader] in extensions.conf does.