TFTP Server in freepbx 14?

Hello it has been a long time sense i have tried to setup tftp server. So i was wondering how hard would it be to setup the TFTP server in freepbx 14 compare to the older one i was using the freepbx 12?

It wouldn’t be hard at all since TFTP is already installed on FreePBX 14. Well at least the Distros, if you did a manual install you have to install a TFTP server.

It took me a very long time to setup the tftp server in freepbx. I honestly don’t remember how it was setup i was using freepbx 12 at the time. I was just messing around, Learning it and what not. Because i have some cisco phones that has templates that needs to be on a tftp server on freepbx. So not even sure

Are you using the SNG7 ISO for this? Yes or no?

The one straight from the site it says STABLE SNG7-PBX-64bit-1805-1 FreePBX 14 • Linux 7.5 • Asterisk 13 or 15 With all the default settings setup. I haven’t changed anything yet besides the admin password and Added a Manual ip address.

So then as I said, TFTP is already installed and running. Files would go in the /tftpboot directory

Hello Blaze Studios Thank you. I’m glade they added it and have it automatically setup. Last time it was a little crazy trying to set it up.

Thanks

The FreePBX Distro has always had the tftp service, and until 14 it was enabled by default. In 14 (SNG7), tftp is disabled by default for security reasons, but you can enable it in the GUI if you have System Admin Pro. Without sysadmin pro you can enable it manually by editing /etc/xinetd.d/tftp and restarting the service.

1 Like

Thank you for the information lgaetz

1 Like

Thread after thread say what you posted, and there is no “enable” in /etc/xinetd.d/tftp on a clean install. And the old phones don’t use HTTP provisioning. And I don’t think I need to use a 3rd party tftp service. So using " STABLE

SNG7-PBX-64bit-1805-2

Release Date: May 2018
FreePBX 14 • Linux 7.5 • Asterisk 13 or 15"

default: off

description: The tftp server serves files using the trivial file transfer \

protocol. The tftp protocol is often used to boot diskless \

workstations, download configuration files to network-aware printers, \

and to start the installation process for some operating systems.

service tftp
{
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -v -s /tftpboot
disable = no
per_source = 11
cps = 100 2
flags = IPv4
}

How do you enable it please???

Note to self it is enable on a clean install?? Please disregard other comment that it is not enable and on the version listed it is enable. And it may be from the “disable = no” but I can’t say.

No idea what you are trying to ask or say. Please type it out again.

1 Like

TFTP is installed and active by default on FreePBX 14 (and older versions). So what is the issue you are having exactly?

It was on and working when I got done with the FreePBX 14/Asterisk 15 install I did this weekend.

Caveat - I installed a couple of “other modules” (include SCCP Manager, Chan-SCCP-B, and Commercial Sysadmin) that may have diddled about with the /etc/xinetd.d/tftpd entry, but by the time I was ready to test, all of my phones were pulling configs from TFTP.

Hello i had a problem with my freepbx after i enable the tftp server part it worked and everything was okay into a week ago. For odd reason the server keep rebooting 3 sometimes 4 times a da. So we change servers and i reinstalled freepbx and also renabled tftp server. Everything looked okay. When i went into the tftp server part the folder was empty. When first did it back in November it ws able to see some times plus a folder for backup. But now nothing is there. I’m using the one i did back in Nov of last year. Not sure what to do now Can someone please help me out?

Joseph

It sounds like a security issue.

I recommend turning off TFTP, never setting it to auto-start, and only turning it on temporarily when you absolutely need it eg. Move-Add-Change-Delete (MACD) or firmware updates of phones – even then it should probably only be used on a separate VLAN to bootstrap from TFTP in to something more secure such as HTTPS provisioning methods that require user/pass.

Most phones will keep locally cached copies of their SIP credentials, which are used if the provisioning server cannot be contacted, but you can try it yourself – turn off TFTP then reboot existing working phone.

Just try not to turn off TFTP in the middle of file transfers.

Hello the problem is there was a few files and a backup folder that came in the tftp folder area on the 14 one back in November of last year. And i had to reinstall freepbx again becuase we lost the server. Before i even enable tftp server the folder was completely empty. When i enable the tftp server it was still empty.

Normally, the TFTP directory IS empty until you fill it. The normal ways to do this are:

  • Run EPM (commercial or OSS) and install the files for your phones.
  • Copy the files from an existing TFTP directory.
  • Run the SCCP Manager (if you are using Chan-SCCP-B) to fill the directory.

What you are describing sounds perfectly normal to me.

Hello thank you i will give it a shot tomorrow.

Joseph

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.