TFTP issues

Unfortunately I have to leave the office for a bit. I’m not sure what else I can suggest from here. The daemon is running, and the phones are querying it, but it seems the files aren’t getting served.

You might want to investigate the command line options for the daemon and see if you can turn on any verbose logging or something.

Hi,

I have been experiencing this same issue with tftp. With a fresh install my cisco phones would not see the files on the ftp root. The status message they reported… file not found. They seemed to find the server, but not any files.

My solution, which I do not like, is I am running a virutal machine (Windows) that runs a tftp server and DHCP. This setup works, but I would like to get it all on the phone machine.

Any ideas as to why this might happen? I have checked everything in the system and it seems normal, the phones just will not load files from the tftp server.

Thanks,
Tom Polak

I ran a test by putting a new HDD in the box and doing a clean install to it. All works fine. It is just a matter of finding out what was stopping it in my old setup…

Odd, since there was nothing custom aside from the aastra scripts…

Hi all:
I’ve been searching for an answer to this tftp problem too. Nothing worked until I added the port number to the tftp server ip address in the phone–
192.168.1.110:69
Polycom IP 301
It worked like magic.

Hope this helps!

I get this result,

[email protected]:~ $ /etc/xinetd.d/tftp file?
-bash: /etc/xinetd.d/tftp: Permission denied

whem i also check the tftp.service, no such file

[email protected]:~ $ /etc/avahi/services/tftp.service
-bash: /etc/avahi/services/tftp.service: No such file or directory

Please help out