Telstra (Australia) SIP

Telstra SIP Trunks do not operate using the standards that all other SIP Trunk providers use. They butchered their SIP product (called DigitalBusiness or DOT) intending to make their trunks only operate on approved hardware. (that they remote manage). To the point that their routers intercept and modify DNS records.

However, geniuses on the whirlpool forums deciphered the requirements to get Telstra SIP working with FreeBPX (Credit to Rob Thomas (xrobau) on Whirlpool Forums Australia). His forum post can be [read here.].

I have followed the instructions in this post and at times I can access the SIP Trunk but other times I cannot.

I am getting 403 FORBIDDEN messages back from Telstra.
Is there someone that is able to help get this working for me?

pjsip.registration_custom.conf

[dot]
type=registration
transport=0.0.0.0-udp
outbound_auth=dot
retry_interval=60
fatal_retry_interval=30
forbidden_retry_interval=30
max_retries=10000
expiration=3600
auth_rejection_permanent=no
line=yes
endpoint=dot
contact_user=089386XXXX
server_uri=sip:digitalbusiness:5060
client_uri=sip:p089386XXXX@digitalbusiness
outbound_proxy=sip:wa1-n.business.connect.telstra.com

Which shows as registered

raspbx*CLI> pjsip show registrations
 <Registration/ServerURI..............................>  <Auth..........>  <Status.......>
==========================================================================================

 dot/sip:digitalbusiness:5060                            dot               Registered

but pjsip logger shows

<--- Transmitting SIP request (645 bytes) to UDP:192.148.131.164:5060 --->
REGISTER sip:wa1-n.business.connect.telstra.com SIP/2.0
Via: SIP/2.0/UDP 144.139.XXX.XXX:5060;rport;branch=z9hG4bKPja382ec04-85c3-4167-a970-3874b8ca0b35
From: <sip:p089386XXXX@digitalbusiness>;tag=6db11117-cce5-4d8b-9232-d5ae85ebd73a
To: <sip:p089386XXXX@digitalbusiness>
Call-ID: 0ccda1a8-a97b-4939-9fec-950a4d3de9a5
CSeq: 37980 REGISTER
Contact: <sip:[email protected]:5060;line=bvvvagq>
Expires: 3600
Allow: OPTIONS, REGISTER, SUBSCRIBE, NOTIFY, PUBLISH, INVITE, ACK, BYE, CANCEL, UPDATE, PRACK, MESSAGE, REFER
Route: <sip:digitalbusiness:5060>
Max-Forwards: 70
User-Agent: FPBX-15.0.16.75(16.21.1)
Content-Length:  0


<--- Received SIP response (506 bytes) from UDP:192.148.131.164:5060 --->
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 144.139.XXXXXX:5060;received=144.139.124.253;branch=z9hG4bKPja382ec04-85c3-4167-a970-3874b8ca0b35;rport=1052
From: <sip:p089386XXXX@digitalbusiness>;tag=6db11117-cce5-4d8b-9232-d5ae85ebd73a
To: <sip:p089386XXXX@digitalbusiness>;tag=2023031741-1701241429883
Call-ID: 0ccda1a8-a97b-4939-9fec-950a4d3de9a5
CSeq: 37980 REGISTER
WWW-Authenticate: DIGEST realm="digitalbusiness",qop="auth",nonce="BroadWorksXlpjf80hnTsuq6ckBW",algorithm=MD5
Content-Length: 0

I would really love to get this working if anyone is able to help please?

There is also [this article.] which suggests I may have to setup a DNS server for digitalbusiness hostname but i am not sure where it should point to.

Please help?

403 on OPTIONS (as shown pre-edit) is not considered an error.
401 on REGISTER is normal, it challenges for the request to be re-sent with authorization info.
Since your endpoint shows Registered, I assume that the retry was successful.

So what is actually going wrong? What happens on incoming calls? On Outgoing? Paste the Asterisk log for a failing call (with pjsip logger on) at pastebin.com and post the link here. If you are too new to post links, just post the last 8 characters of the URL.

Thank you for the reply @Stewart1

Upon further inspection I found the REGISTER challenge is getting UNAUTHORIZED response back… but i dont’ know whjy?

pastebin. - PDDwVbPF

(deleted)

The paste shows a successful registration and some OPTIONS , but no attempted call. Are you sure that a call was attempted during the period covered by the log?

Thank you @Stewart1

I was able to get a call through once.
However now I get “All circuits are busy now” message.

Here is the pastebin of attempting to call out.
pastebin AQwTCtZr

I really appreciate your help on this.

Try setting Outbound Proxy:
sip:wa1-n.business.connect.telstra.com\;lr\;hide

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.