System Updates Stuck in Loop [Errno 12] Timeout & yum lock


(Brad May) #1

FreePBX 14.0.13.40
PBX Distro: 12.7.6-2002-2.sng7
Asterisk Version: 13.32.0

It’s been a while since I’ve seen any system updates available in the GUI Dashboard. Recently I saw a bunch of updates show up, so this morning I decided to update them, and it seems to get stuck with the following output:

http://sng7.com/os/7.8/os/x86_64/Packages/device-mapper-persistent-data-0.8.5-2.el7.x86_64.rpm: [Errno 12] Timeout on http://sng7.com/os/7.8/os/x86_64/Packages/device-mapper-persistent-data-0.8.5-2.el7.x86_64.rpm: (28, 'Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds')
Trying other mirror.

Eventually (I guess after it tries all the mirrors it knows of) I start seeing this message repeating:

Another app is currently holding the yum lock; waiting for it to exit...
  The other application is: yum
    Memory : 152 M RSS (552 MB VSZ)
    Started: Fri Oct  9 07:48:54 2020 - 37:42 ago
    State  : Sleeping, pid: 12177

I found another post in these forums that seemed to be similar, and one of the recommendations was to reboot. I rebooted the server early this morning, and I ran yum update from the console, and still saw similar errors. At some point (I don’t remember the exact order of events…) I was unable to connect to the server over the network. I rebooted again, and I could access it again. After the 2nd reboot, I tried System updates from the GUI again, and I’m back in the same situation outlined above.

Everything seems to work (web interface, phone calls, etc…), but I’d like to keep our server updated.

I’m not a Linux pro, but I can manage files & run commands if instructed what to run. Any assistance is appreciated.


(Brad May) #2

Well…now when I go back and check for System updates again, it says there are none available, as if it finished updating. Is that what happened, or should I look for anything else?

Thanks!