System Update has been running for over 2 days

Our Freepbx 14.0.11 has been running a System Updates for over 2 days. The progress screen keeps saying things like “I’m still alive” and “Progressing through upgrades”.

The currect PBX vesion is: 14.0.11
Current system version is: 12.7.5-1902-3.sng7

The 10 packages listed as being worked on:
Updating : asterisk-version-switch-5.2-1.sng7.noarch 1/10
Updating : openvpn-2.4.7-1.el7.x86_64 2/10
Updating : htop-2.2.0-3.el7.x86_64 3/10
Updating : redis-3.2.12-2.el7.x86_64 4/10
Updating : incron-0.5.12-11.el7.x86_64 5/10
Cleanup : asterisk-version-switch-5.1-2.sng7.noarch 6/10
Cleanup : openvpn-2.4.6-1.el7.x86_64 7/10
Cleanup : htop-2.2.0-1.el7.x86_64 8/10
Cleanup : redis-3.2.12-1.el7.x86_64 9/10
Cleanup : incron-0.5.10-10.sng7.x86_64 10/10

No error messages I can see.

I’m thinking the update to stuck looping, but I’m not sure how to check what it’s doing.
There does not seem to be anywhere to stop the update, other then rebooting our switch. I’m concerned there could be problems if I reboot the switch while it updating.

Any suggestions? Recommendations?


Our PBX is now randommly freezing.
No calls can be completed.
When I reboot, the system works for a short time, then freezes again. I’ve had to reboot five times today.

I don’t see any errors in the logs.

I think our problems are solved.
Working with support, they updated our version of Asterisk to 16.3.0.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.