System Update Failing

Went to update a client’s SNG7/14, which I keep updated on a bi-weekly basis, and received the following error on yum update (or yum upgrade)

---> Package selinux-policy-targeted.noarch 0:3.13.1-192.el7_5.3 will be an upda                                                                             te
--> Processing Dependency: policycoreutils >= 2.5-18 for package: selinux-policy                                                                             -targeted-3.13.1-192.el7_5.3.noarch
--> Finished Dependency Resolution
Error: Package: kernel-3.10.0-862.2.3.el7.x86_64 (sng-updates)
           Requires: linux-firmware >= 20180113-61
           Installed: linux-firmware-20170606-58.gitc990aae.el7_4.noarch (@sng-u                                                                             pdates)
               linux-firmware = 20170606-58.gitc990aae.el7_4
           Available: linux-firmware-20170606-56.gitc990aae.el7.noarch (sng-base                                                                             )
               linux-firmware = 20170606-56.gitc990aae.el7
Error: Package: selinux-policy-3.13.1-192.el7_5.3.noarch (sng-updates)
           Requires: policycoreutils >= 2.5-18
           Installed: policycoreutils-2.5-17.1.el7.x86_64 (@anaconda/1710)
               policycoreutils = 2.5-17.1.el7
Error: Package: selinux-policy-targeted-3.13.1-192.el7_5.3.noarch (sng-updates)
           Requires: policycoreutils >= 2.5-18
           Installed: policycoreutils-2.5-17.1.el7.x86_64 (@anaconda/1710)
               policycoreutils = 2.5-17.1.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

This error doesn’t occur on my own identical system on Vultr. I rebooted the target system and the same error occured. This is a VMware VM running on a Dell PowerEdge T610.

Just wondering how I should proceed here.

A very quick Google search revealed:

Does that help?

Thanks for the reply. I have never had to work around a yum update with FreePBX, and I’m concerned that a --skip-broken might “break” something.

Full disclosure, this was an ISO install, plain vanilla.

The link you provided seems to reference an upgrade, and is from 2015 (FreePBX 13 I imagine).

Sorry, I should have been more clear. If you follow the thread to Andrew’s answer, it leads back to documentation for SNG7.

Long and short, Sangoma is recommending you use the published update methods. Can you confirm if you’ve tried this and if it helps?

The prescribed method is exactly what I did. Update modules, reload, and then yum update. So yes, I did it to the letter. And I have many systems out there, and I’ve done this many times before. This is the first time I’ve seen a failure.

Note I’m not trying to do a major version upgrade or anything, just trying to update the ISO installed SNG7/FPBX14. This system was last updated a week or so ago.

Fixed it.

yum clean all
rm -rf /var/cache/yum/*



This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.