System update error

All commands like “yum update” get next error:
Could not retrieve mirrorlist http:(slash)(slash)mirrorlist(dot)sangoma(dot)net /?release=7-8.2003.3.el7.sangoma&arch=x86_64&repo=os&dist=$dist&staging=$staging error was
14: HTTP Error 403 - Forbidden

Update from WEB interface, has next errors:

  • Last Online Check Status: Never (Yum Error)
  • Last System Update: Unknown (System updates not run since last reboot)
  • Updates Available: Unable to run ‘yum check-updates’, can’t check for updates

can someone tell me what the problem is and how to fix?

It would appear that this is a transient error. I’m going to guess that there’s a repo problem again. Try again in a few hours and see if that solves it.

Have same result

Loaded plugins: fastestmirror, versionlock
Determining fastest mirrors
Could not retrieve mirrorlist http://mirrorlist.sangoma.net/?release=7-8.2003.3.el7.sangoma&arch=x86_64&repo=os&dist=$dist&staging=$staging error was
14: HTTP Error 403 - Forbidden

[[email protected] ~]# ping -c 4 mirrorlist.sangoma.net
PING mirrorlist.sangoma.net.cdn.cloudflare.net (104.22.32.150) 56(84) bytes of data.
64 bytes from 104.22.32.150 (104.22.32.150): icmp_seq=1 ttl=58 time=34.5 ms
64 bytes from 104.22.32.150 (104.22.32.150): icmp_seq=2 ttl=58 time=34.3 ms
64 bytes from 104.22.32.150 (104.22.32.150): icmp_seq=3 ttl=58 time=34.3 ms
64 bytes from 104.22.32.150 (104.22.32.150): icmp_seq=4 ttl=58 time=34.5 ms

--- mirrorlist.sangoma.net.cdn.cloudflare.net ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3003ms
rtt min/avg/max/mdev = 34.357/34.478/34.595/0.249 ms

I think CloudFlare block access to mirror list (yum cannot enter CloudFlare captcha)

I have faced the same issue.
Is there a way to resolve it by hand or do I need just to wait for a little?

Only wait while FreePBX team resolve this problem.

Issue is being tracked here
https://issues.freepbx.org/browse/FREEPBX-22945

Can you try again now please?

We’ve tweaked the cloudflare rules, so let me know if we’re still having issues here.

[[email protected] ~]# yum update -y
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
Could not retrieve mirrorlist http://mirrorlist.sangoma.net/?release=7-8.2003.3.el7.sangoma&arch=x86_64&repo=os&dist=$dist&staging=$staging error was
14: HTTP Error 403 - Forbidden

When i open this URL in browser - i am got captcha.

P.S. I am from Ukraine.

I got captcha each time when open (or reload) community.freepbx.org

@SolarW I’ve spent some time troubleshooting the issue with Cloudflare Support and we think we know what is happening. Can you please try again and let me know if you’re still having the issue? Sorry for the back and forth on this.

Now “yum update” working fine for me.
Thanks.

Yum update not working for me today via ssh and gui…

I get a HTTP 416 error " Requested range not satisfiable? Trying other mirror then no more mirrors to try when doing system update via gui and similar during SSH yum update

I am also having this issue yesterday and today.

@mbrooks @lgaetz Should we open a ticket for this update error or is it already being worked on?

Well, that’s definitely a new error given that sng7.com has been in cloudflare for literally years. It appears there is an issues with the asterisk16-g719-2002-5 package. So yes, I would open a ticket with the FreePBX team.

1 Like

Ticket # 1004776 opened

Got a response to my ticket they were able to reproduce the error locally and filed a bug report

I got it to reproduce as well. We had to purge the cache in cloudflare. I ran this and now it works:

yum --enablerepo=sng-pkgs clean metadata
yum update

Yep that worked