System ugrade script; Version issue?

A few months ago I reinstalled the distro so I could upgrade to Centos 6 and restored my Freepbx configuration (or tried to).

I would like to run the upgrade scripts but something seems amiss.

According to cat /etc/schmooze/pbx-version my PBX version is: 1.816.210.58-1 but cat /etc/redhat-release yields CentOS release 6.3 (Final). My Asterisk version is and my FreePbx version is Sysadmin is enabled (which I understood would only work on CentOS 6.x.)

Per: it looks like the systems thinks it is CentOS 5.8 and states that there is no upgrade path to 6.0.

How do I handle this? I assume I shouldn't try running scripts willy nilly.

Thanks in advance!


The version of the distro I had installed was: FreePBX-3.211.63-9-x86_64.

Assuming that the version number was incorrect b/c I incorrectly restored something, I made a backup and tried running the script. This seems to have reset the version to the correct number. I then ran all the scripts through

I now get pbx-version: 4.211.64-7 and redhat-release: CentOS release 6.4 (Final).

Does this seem reasonable? It seems to be working. Please let me know if I missed anything.



If you restored a backup made from a 3.211.63-9 into a 3.211.63-9 and then upgraded your FreePBX Distro to the 4.211.64 track (and, sequentially, to the actual latest minor version -7) by following the shell upgrade scripts rules (as per Wiki instructions) you shouldn’t face any issue.

Thank you Parnassus…

The backup was from an earlier version of FreePBX (I am guessing it was probably the 1.816.210.58-1 that showed up). It was restored to a 3.211.63-9 box.

I ran the 3.211.63-9 script and that updated the version number. I then ran all the the upgrade scripts from after -9 and on so that cat /etc/schmooze/pbx-version now reports 4.211.64-7.

I am not getting any errors and everything seems to be working.

Can I assume all is well?


Hard to tell without an high fly over logs: the first part of backup and restore (done from/against to different versions 1.816.210.58/3.211.63) it’s a little bit worrying…or, at least, should have worried me if I had done that in that way.

From what I’ve read the Backup/Restore is an operation to deploy considering two very equal system, equal from the point of view of FreeBBX’s version…due to (eventually) differences in FreePBX Data Base structures (as it evolves along with main versions/tracks) between the version from which you did the Backup and the version into which you try the Restore.