System suddenly restarted, stuck in startup/reboot loop


(John Jarrett) #61

One of the first things I would do is sit down and write out all of the following known information about the phones and phone system.

Gather up all your DIDs, Direct Inward Dial… these are your telephone numbers. These come from the POTS line or the Plain Old Telephone System. Try and note which incoming cable is which DID or telephone number and might be helpful to have noted which cable went into which port in your DAHDI (FXO) card.

Your extension numbers. Note which phone and where, has what extension number.

Your desk phones I am certain from what I can assume from what all I have read, are IP (VOIP) telephones. These will all be SIP phones that support SIP and PJSIP. Hopefully somewhere someone has written down the IP addresses of the SIP phones and the login information to change, should the need arise, any details inside the SIP phones. We, (not we, but you) need to have the extension passwords that have been set on those phones to register the phones to your FreePBX.

Since your phones are already on port 5060, (old SIP) and now the new SIP, PJSIP, uses port 5060 there is less to change so create PJSIP extensions. The defaults “should” all work after the necesary informaiton, such as extension, user (extension) and password are set up.

You will create a DAHDI trunk for each DID, incoming telephone number. After installing the card FreePBX “May” see the card, properly identify it and provide you with three found ports that you can add. One port number per DID and trunk. I think you said you had three lines coming in. I haven’t messed with old POTS and DAHDI cards in years so I am pretty rusty. I KNOW that others will help a bunch more than me.

Once you are successful with your trunks, which I’d set up first, I’d move to my extensions. Then you need Incoming routes, which points a DID to a destination, like an IVR or that “Hello! Thanks for calling… push one for the boss…” and etc.

Then an outgoing route. Some of the difficult stuff might be in the Dial Patterns in Trunks and Outgoing Routes. I know folks can help you with that.

For now, get the basics set up Trunks and extensions. This pdf might help you if you don’t over think it and don’t let it confuse you. There is a lot of extraneous stuff in it.

This might help you a bunch:

https://wiki.freepbx.org/display/PPS/FreePBX+Distro+First+Steps+After+Installation

A PDF version can be found here

I hope this might get you on the path to recovery!

And once this is all done, port your numbers to a SIP provider and get good reliable and very very inexpensive telephone communications!!

John


(Dave Burgess) #62

Anything that needs a SIP connection (mostly your phones and your maybe your backup ITSP connection) should be set up in PJ-SIP.

An important point that new people don’t sometimes get is that SIP is SIP, so if your provider or your phones have “Chan-SIP” examples, you can still use PJ-SIP at your end to connect to these. As the ‘edge cases’ for PJ-SIP not working are ironed out, we should try to steer clear of Chan-SIP as much as possible. I know there are still cases where Chan-SIP is required, but these are exceptions instead of rules.


#63

Okay, I’ve followed everything to a “T” — including some help I got from remembering that I had taken screenshots of several FreePBX setup/settings pages back in 2015. I found an old folder of screen grabs showing our old Dahdi settings, trunks, etc. I replicated those settings exactly.

It was actually set up to only use one DAHDI Channel g0 trunk… which was used by one inbound route (must be kind of a “catch all”?)… which directed to a time condition that ruled that during business hours it should direct to the IVR. Does that make sense?

All three phone lines are plugged into the FXO card. They all light up in green on the physical card on the back of the computer. If I go to DAHDI Configuration and click on the Analog Hardware tab, it shows “FXO Ports — 1,2,3,4”. Each port’s settings are Signaling: Kewl Start, Group 0, and Context: from-analog.

On paper everything is set up and working. However, when I call into the shop, it just rings forever before hanging up. It never triggers the IVR.

What else can I be missing?

[EDIT] I do see one error showing up on the dashboard now:

Unable to write to /etc/wanpipe/global.conf
Please change permissions on /etc/wanpipe/global.conf or disable Sangoma DIGIUM mode

I have no idea how to change permissions. For now I’ve tried going into the Module Admin and disabling both the Digium Phones Config and Digium Addons modules (though I’m not sure that’s technically the "Sangoma Digium MODE it says to disable — not sure where to disable that)… as we are using Polycom and not Digium phones. But either way, disabling those modules did not get rid of the error. Not sure if this error is contributing to a DAHDI problem that’s keeping the system from working?


(Lorne Gaetz) #64

From Linux command line:

touch /etc/wanpipe/global.conf
fwconsole chown

Are outbound calls working?


#65

No, outbound is not working either. If I dial out from one of the Polycoms, nothing happens… there’s a dial tone when I pick up, but after dialing it just says “Connecting to” the number and silence. No ring, no busy signal, just silence.

BUT, I don’t think I have the phones set up correctly yet. This was a screenshot from our old system:

If I got to Settings > Endpoint Manager it looks like I need to buy the commercial module for $149 in order to set up all the phones? Unless what used to be called “Current Managed Extensions” is somewhere else?

I CAN log in to each phone via IP address and edit settings. I set our PBX IP address to the same fixed IP as the old, so all the phones still have the correct IP set. But not sure if anything needs to be changed on the phones themselves, either via the PBX interface, Endpoint Manager, or individual IP logins.


(Moussa) #66

You do not need Endpoint Manager unless you have hundreds of installations.

I assume the phones are still on the same old configuration. I also assume Chris has two extensions on his phone. Let’s start with extension 223.

  • On FreePBX, create an extension 223 for Chris. Note the extension’s Secret
  • On Chris’s SoundPoint 330, you need to type the extension 223, the PBX IP address and the Secret (>> most likely has changed with the new installation)

If things worked fine, you will see the phones registered: Report >> Asterisk Info


(Luke C) #67

EPM is a must, even on a 10 phone system for me. Quick and easy, on to the next install!
Time is $$$$$$$$$$$

Not to mention, if I have to edit polycom sidecar BLFs on multiple phones. That can be done in about 10 seconds flat.


(Itzik) #68

While I agree that EPM makes our lives so much easier, It does not seem like the old system had any changes done since it was purchased. If that’s the case, it’s a one time registration for each phone and that’s it.

Additionally, OP mentioned that he’s the “IT-ish” guy. Setting up provisioning is sometimes harder to learn that simple SIP Registration.


#69

I’m okay logging in to nine IP addresses and changing a couple settings. I can have that done in half an hour… as long as I can find the right info. I set up the extension and have the secret. The server IP stayed the same (I set the new server to the same static IP as the old one was, so ideally the phones won’t need that changed).

The only thing I don’t see in the Polycom web interface — that’s where I’m looking, correct? typing the IP address of my phone into a browser and logging in with Polycom/456? — is where to paste the secret.

[EDIT] Is that “Authentication Password”?


#70

Got incoming calls to work! Soooo cloooose…

Dialing in triggers the IVR as it’s supposed to, and I can type extensions (i.e. 223) but it just goes straight to voicemail and the phone at desk 223 does not ring. The phone itself is still not recognized and cannot receive incoming nor make outgoing calls.

So I think I’m okay on the trunks and all that; now it’s just getting the phones to be registered. I tried pasting the secret # into the Authentication Password field in the Polycom web interface (accessed via the phone’s IP address in a browser), but no dice. I’ve rebooted the phones as well as FreePBX. With three extensions set up, the Asterisk Info report shows:


(Moussa) #71

I think so, but your phones are still not registered. Can you take a screenshot?


(Dave Burgess) #72

There’s a really important file called /var/log/asterisk/full that you need to know about. If you can, open an SSH session to the server, log in as ‘root’, and type “tail -F /var/log/asterisk/full”.

It will give you a screen of everything that’s happening on the PBX part of the server.

Also, there’s a “momentary confusion” piece on setting up extensions. There are two passwords on the extension setup page. The top one is for the phone (the Authentication Password) and the bottom one is for the user to log into UCP.

BTW - once you get this set up, your people are going to love UCP.


#73

Okay, here is the Polycom setup. I looked at the settings menu IN the actual phone and got its IP address. Went to that IP in my browser and logged in with user Polycom, password 456.

In “Authentication Password” (fourth field down) is where I pasted the Secret from the FreePBX Extensions module.


(Lorne Gaetz) #74

Confirm you are using the correct port. The phone by default uses 5060, but the SIP account for the extension may not be. The SIP port is displayed at the top of the page when you edit an extension.


#75

Yeah, looks like it:


#76

Do I need to change the Transport? Or any other settings from the old phone configuration?

Transport

Right now it’s set to “DNSnaptr” but I have no idea what that or the other options in the dropdown are, so for now I haven’t touched anything.


(Lorne Gaetz) #77

Extension is configured to use UDP transport, so that seems like a good place to start on the phone.


#78

Yeah that asterisk log is showing “Error 171060 Unsupported Transport” so I think that’s looking promising to change DNSnaptr to UDPonly.


#79

Okay, we have progress, but for some reason it’s not sticking and the phones will not stay registered/online with the server. I changed the transport to UDPonly, and suddenly I was able to dial outbound from my phone. I successfully called my cellphone from my desk Polycom. I changed two phones and both showed as ONLINE under Asterisk Info. And the villagers rejoiced! But their joy was short lived.

I tried calling intra-office (extension 223 to 222) and it wouldn’t go through. It just sat there on “Connecting to…” but wouldn’t ring the other phone. I changed the transport on the “nicer” phone up front which required a reboot, so I rebooted the phone… no luck. Restarted DAHDi and Asterisk from within FreePBX, waited for everything to fire back up… and now all three phones are back to showing Offline. Now I can’t dial that same outgoing call to my cellphone that just worked 10 minutes ago. It just says “Connecting” in silence, same as intra-office calls.

On the inbound, I can call the office and the IVR will pick up. But same as yesterday, when I dial an extension it won’t ring and just goes straight to voicemail (“the user at extension 223 is on the phone” greeting). I thought maybe the phones didn’t save the transport but I just checked the phones on the Polycom web interface and the settings have been saved correctly… UDP transport is still set.


(Moussa) #80

Do tail -F /var/log/asterisk/full again and make an outbound call, then copy and paste the result