System recordings in two different languages, german, english


since the latest update to freepbx 13, I’ve problems with my system recordings/announcments.
if I call the feature code *xxxx for the system recording, I get the following response:

[2016-04-05 07:12:14] WARNING[3979][C-000000ad] file.c: File de/custom/Urlaubsansage does not exist in any format
[2016-04-05 07:12:14] WARNING[3979][C-000000ad] file.c: Unable to open de/custom/Urlaubsansage (format (ulaw)): No such file or directory
[2016-04-05 07:12:14]
WARNING[3979][C-000000ad] pbx.c: ast_streamfile failed on
SIP/30-0000017e for de/custom/Urlaubsansage,m,de,macro-systemrecording

so I looked in the directory /var/lib/asterisk/sounds/de/ … there is no custom directory… only /var/lib/asterisk/sounds/en/custom exists…

if I call an extension where the destination is set to the announcement “Urlaubsansage”, I get the correct announcement played…

so I now copied the announcemnts of /var/lib/asterisk/sounds/en/ to /var/lib/asterisk/sounds/de/, but if I change the announcement with the feature code, it is changed in the wrong directory, so the old announcement is played if I call the extension…

in freepbx webgui if I go to Application -> Announcements and select the “Urlaubsansage” announcement, I only have the option “File list for english”, but I’m not able to select the german language or the german diretory /var/lib/asterisk/sounds/de/custom …

anybody knows how to fix this?


I’ve just figured out, that I have to add a Sound language via Web GUI Admin -> Sound Languages and set the Global Language to my new created language (german in my case).

found at

now if I call the extension where the announcement is set, the sound from the correct location /var/lib/asterisk/sound/de/custom/ is played. but if I want to edit this system recording, I get an xxx-TMP.wav file, and the old system recording is not overwritten.

a known bug? didn’t found anything about this

seems like the customer didn’t accept the new recording by pressing the “2” key… testet it myself in my environment, here it worked