System Recording module crashes

Dear all,
What is the good advise to follow in case I cannot add a Custom Recording. When I hit button ‘add’ on the top left corner system hangs for a long time and then I see

Whoops \ Exception \ ErrorException (E_ERROR)
Maximum execution time of 30 seconds exceeded

message in my browser.

This happens with System Recording module only. All other modules work fine. As far as I can judge this prevents me from create Announcements for IVR…

Any advise is appreciated.

Looks like you have corrupt UTF8 on your system.

I would really appreciate any hint on how to fix it. Thank you.

Sorry I can’t provide further input. You have a file on your system (or many files) that have UTF8 in the file names in the Asterisk sounds folder. Since Asterisk can’t reliably read UTF8 in file names these files won’t work well so you should remove these files.

Andrew, are you referring to /var/lib/asterisk/sounds or anything else? where do I look for them?

Andrew, I went ahead and cleaned up /var/lib/asterisk/sounds/en/custom directory. Restarted the fwconsole. However, I still see the following message on the Dashboard (assume it may have something to do with my problem):

> The file format sln48 is not supported by Asterisk when it should be. Audio conversion quality will be limited to 16k instead of 48k

and the original problem is still there…

That has nothing to do with your issue

You need to clear out /var/lib/asterisk/sounds/

everything. Some file in there is causing your issues.

It looks like I may damage my FreePBX system… or not? - sorry i am trying to be careful before I make something irreversible. My Raspberry Pi runs remotely so i cannot access it physically.

You can redownload languages through the Sound Languages module if need be. But you have a file in there that is causing crashes.

Thank you, man! It worked. You saved my day.

You also have a Raspberry Pi, which will unfortunately for you destroy a really important file for no apparent reason at exactly the time you don’t want it to happen, You will need to immediately boot to the image you made yesterday when it worked , If you don’t have that image, you need to start preparing for that need :wink:


Once I saw “Raspi” I assumed the invalid utf8 was infact a corrupt file.

I appreciate your advise, however I am a bit unclear - why my Raspberry Pi can threaten?

Because the storage on your file system on your memory card is just basically unreliable. If a sound file breaks not a biggie if /usr/bin/asterisk or /boot/initrd* breaks then you will have a bigger problem.

1 Like

Makes perfect sense! I will try to think of any way to remotely backup my installation to some safe place. This is my home installation with a few dongles and trunks. It was smoothly running for the last 8 months with a less then 10 reboots. But I read that Raspberry Pi can easily make my SD inoperable.

Hi all.

Got a near similar issue with Freepbx
When uploading a .wav record file a popup message opens “There was an error, See the console for more détails”

And nothing is uploaded nor transcoded…

Any help ?


Did you look at the console?

Thanks for replying.

Nothing in the console… Nor in log files !
But I think I found the issue.
I’m trying to upload waves files generated by a TTS that are in .wav format.

The workaround is to convert thoses files via VLC to mp3 output files then upload the mp3 file and it works !

2 possibilities:

  • my files are all corrupted
  • transcoding process is unable to convert .wav files.

Hope this can help.