System quit working

I recently installed the latest version I downloaded from the website, but since the web interface is not working I do not know the Distro, Asterisk versions. Here is the error message when I log on via ssh:

PHP Fatal error: Incompatible file format: The encoded file has format major ID 4, whereas the Loader expects 7 in /var/www/html/admin/modules/extensionroutes/functions.inc.php on line 0
Whoops\Exception\ErrorException: Incompatible file format: The encoded file has format major ID 4, whereas the Loader expects 7 in file /var/www/html/admin/modules/extensionroutes/functions.inc.php on line 0
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/admin/modules/extensionroutes/functions.inc.php:0

After the problem I have run yum upgrade and there were many updates. When I attempt to log in via web interface I just get an error message. As it is 1.- you can call out, 2.- calling extensions works, 3.- web interface does not work, 4.- incoming calls are not answered nor a voice message given.

James

Which version of the distro

Since I cannot get on the web interface I do not know, but a month ago I installed the latest version off the Internet. If you tell me where to look I will get the info back to you asap. I have ssh access to the pbx.

cat /etc/schmooze/pbx-version

image

12.7.5-1805-2.sng7

Did you restore a backup or something?

No I didn’t. There were a lot of updates yesterday, and from the web interface I updated them, needing to do it several times because of dependencies. During the last update there was this error message that came up in the web interface, and I could do nothing there. When I log in via ssh I get the same message at login.

1 Like

I might mention our Internet was a bit flaky, but the problem happened after all the files were downloaded.

fwconsole ma upgradeall
fwconsole reload

This error also comes in the log file:
[2018-05-31 15:28:22] WARNING[7914][C-00000009] app_dial.c: Unable to create channel of type ‘DAHDI’ (cause 0 - Unknown)

fwconsole doesn’t work. I just get the same error and it does nothing.

rm -Rf /var/www/html/admin/modules/extensionroutes

OK. That worked. I can get into the gui. Now I have 1 unsigned module, 2 disabled modules, and a broken module (extension routes). The disabled on is Zulu which we are not using at this time. I will work on this. Any suggestions will be helpful.

The web interface works now, but I don’t see extension routes module. How can I add that? Or is it called something else? Incoming calls do not get routed to the phones yet.
On the dashboard there is a tag that has this brown message in it:
The system detected a problem trying to access external server data and changed internal setting MODULEADMINWGET (Use wget For Module Admin) to true, see the tooltip in Advanced Settings for more details. (20 hours ago - about the time the trouble started)

Well you deleted it.

fwconsole setting MODULEADMINWGET 0
fwconsole ma downloadinstall extensionroutes

This is what I get on the last command:
[[email protected] schmooze]# fwconsole ma downloadinstall extensionroutes
No repos specified, using: [standard] from last GUI settings

Downloading module ‘extensionroutes’
The following error(s) occured:

Extension Routes is not available to you

fwconsole ma listonline

Seems to be working. I had to restart Dahdi. Zulu is still not working with this message: Unable to run module Zulu: - Failed to run installation scripts."
We are not using Zulu at this time, but may in the future.
Thanks for your quick help. Thank-you very much.

James

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.