System Firewall service shows as not running

firewall
configuration
freepbx
Tags: #<Tag:0x00007f70240cc498> #<Tag:0x00007f70240cc2e0> #<Tag:0x00007f70240cc128>

(James) #1

PBX Version: 13.0.197.28
PBX Distro: 10.13.66-22
Asterisk Version: 13.18.3

On the dashboard our Firewall service is showing as not running however I am able to access the firewall area under connectivity > firewall. Whats going on?

Also i noticed that I cannot access the intrusion detection tab in system admin, I get an exception error /­var/­www/­html/­admin/­modules/­sysadmin/­Sysadmin.class.php1767

We are running Firewall module version 13.0.60.14


(Brett Seedhouse) #2

Same Here.
I had to roll back to 13.0.60.3 to get the firewall status running again.
However I still can’t get into system admin > intrusion detection. Returns an exception “Could not get banned list”.
I did notice on one of the updates it did say that ipset was not installed and was a requirement. However I don’t remember which module required it… as it did say to run “yum install ipset -y” and try again… except i cant remember which

The modules I last installed were as follows.
certman 13.0.48 (current: 13.0.41)
firewall 13.0.60.14 (current: 13.0.60.3)

when installing them thats when it said it needed ipset

edit update.


(James) #3

Glad to know its not just me.
Whats the easiest way to rollback the version?


(Brett Seedhouse) #4

Admin > Module Admin. click “Check Online”, then expand “System Firewall” rollback will appear under Info & changelog (it wont otherwise).
Then just rollback to your previous version. Mine was/is 13.0.60.3.


(James) #5

Thanks, worked for me too.
I’m going to start another thread regarding the error page when trying to access the intrusion detection area


#6

Same issue here. Firewall is not running and Intrusion detection returns an Exception error.


#7

Rollback System Admin to 13.0.94 to fix the Exception error.
The firewall error may only appear if Responsive Firewall is not enabled.
In my case we don’t have SIP endpoints and don’t use the Responsive Firewall option.


(Mark Wass) #8

Do you have link to that other thread? I’d like to follow this issue as I too had to roll back to get this fixed.


#9

I confirmed that the firewall error appears on the Dashboard even if the Responsive Firewall is enabled.


(Reinhard Stindl) #10

Same here…on two systems, 14.0.13.40 and 15.0.16.75…responsive firewall is on…after updating the firewall module…firewall stopped running. I could start it with fwconsole, but next time I restarted the machine, it was off again.

I switched back to the previous version of firewall.

Why is there no email alert, when the firewall is off? Isnt this serious? Especially with external extensions or Sangoma Connect?


(Lorne Gaetz) #11

I have a 14 and 15 system running Firewall module versions 13.0.60.14 and 15.0.6.29 respectively. Initially, I thought I was seeing the same thing, where the voipfirewalld daemon did not start on boot. But on both systems the firewall service did start, it just took longer than expected, about 10 minutes after boot.


(James) #12

The fix can be found on this thread


(system) closed #13

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.